Download

Almost can't get rid of landscape material instance references

Just experimented with landscape materials. Works so far. Removed a old material instance to be replace by a new one. Good so far. Then deleted the old matieral instance and tried to rename the new one to the name of the old, deleted instance. NOT POSSIBLE. UE always tells me that this material exists and I can’t use this name. Reload UE, restart, nothing worked. UE stills thinks this reference exists and doesn’t allow me to set the new instance with the same name. Strange for me so.

How can I get rid of this old reference information. Notices a lot of times, that UE remembers more as I prefer. And does not expose this information for editing.

Of course I can create a new map, reimport the landscape, assign the new material instance and fine. But from a development point of view, this is a pain in the ■■■.

Tried Replace References on map, but doesn’t seem to work. On landscape level this option is not available.

Should I delete build data? Layer infos? I already removed the materials from the landscape. So why, in gods name, are there still references, which even the reference viewer doesn’t expose?

I’m sure still a command line and coding guy, so editing some files is no issue. If I could find the point where UE stores ■■■■■■■■ information. The old material instance with that name doesn’t even exists anymore.

In fact what I currently did is, close UE, rename the f… asset on file explorer level and delete before the asset NOT SHOWN in UE (with the old name).

This is far away from any meaningful development process, by the way.

Hey great, written something like useless, incorrect, unusable information, but this got censored, not the f… which may be worth of getting censored. omg

Explanation development process (from my limited point of view):
Over and over you redefine an object or whatsoever, with the final name. Until it works. Only backups get different names. If I’m working on a tree, this object names <my_game_tag>_tree. In every version. Old versions are either deleted (in the beginning of the process) or renamed to whatevernam _ version_tag if necessary. Using local git, I don’t even have a need for naming, I simply delete and replace the old version with the new version. If the tool allows me to do so …

All you had to do was to right click the project folder and choose the fix references option before renaming the file.

Before? Ok, thx, just learned something

After any deletion.
The editor keeps whatever it can in memory for fast access.
When deleting and moving folders the built in function helps flush out the stuff you removed or moved.

Ok, I’m trying to catch up. Got on folder level only “Fix up redirectors in Folder”, no explicite fix references option. Project settings or unclear definition MostHost_LA?

And about “The editor keeps whatever it can in memory …” - therefore I even restarted my laptop. Probably I have an old fashion view about memory, but restarting an app should not give me old memory references. But ok, I’m old, I’m learning,

Btw. thx for fast reaction.

That was the right option. Redirectors, not references.

Re memory.
Yes starting a project clean cleans up memory, but not redirectors.
Those are stored locally in the UAsset files…

Good to know, thx a lot

After learning in this thread: UE/Epic Games don’t you think, you should expose uasset files, if they still exist? So someone is able to handle it (delete, rename, whatsoever …). I found it disgusting, that my file explorer showed my UE uasset files, that I couldn’t see in the content browser. Thus getting a little bit paranoid about why can’t I rename this asset. If you tell me in the error message, this asset already exists, wouldn’t it be nice, to show me the asset?

Diving deeper, an option to rename or delete the uasset file with lost references would be great.