Aiming True FPS problem.

I will try to explain what I am trying to do:
I attach a camera component to a gun, and then blend from the player camera to that camera when the player is Aiming.

The problem i have is shown in this video:

When I try to aim, the camera automatically aim to the ground.

Here i post the code i am using and the camera configurations.



Cast<ASPlayerController>(MyPawn->GetController())->SetViewTargetWithBlend(this, 0.20f, VTBlend_Linear, false);


note: I am using the “survival project” that is being developed by Tom Looman as a “base” to test this “aiming solution”. (Ongoing C++ Gameplay Example Series: Making a Survival Game - Announcements and Releases - Unreal Engine Forums)

Hope you can give me an idea what is going on
Thanks in advence an sorry for my English.

bump.
I still have the problem and i cant figure out what could it be.
I don t know if i can provide more information, but basically the problem is shown in the video. (When i change the camera to the camera on the weapon the player lost vertical control of the aiming and it keep aiming to floor).
I opened a question on answer hub without much luck yet.

thanks.

Hey this should fix your problem.
a0f37dbf2f182f4eb2f00fe204d9db5a7761a9ed.jpeg

Kevin194, thanks you very much for your answer, i did that, but im having the same effect.
I recorded a new video showing this time the configuration that you mention and then unchecking inherit Pitch.
With inherit Pitch unchecked, the aiming doesn’t go to ground, but i cant move the camera horizontally.

Strange… I had the same issue as you but for me when i checked Use Pawn control rotation it worked normally

Yes it is. :confused:
Well i am trying to add more information, I changed the pawn mesh to the default unreal skeleton, i have the same issue but different. I am Still losing control of the Pitch, but in this video i get some strange movement patron when aiming. (in this video im not moving the mouse at all when aiming)

Ok I finally get it working. Now it needs some tuning on animation and hands placement, but is a good start. Thanks.

Hey,

Im having the same issue :frowning:
Can u share how u fixed the issue please?

Kind regards

Hello, we are also experiencing that same issue. Alexarg you seemed to have solved it, can you post how you did?