Download

Advanced Sessions Plugin

Start and stop networked voice are only for push to talk, if you have push to talk off then it should always be on.

There is a microphone threshold variable though Set Mic Threshold | Unreal Engine Documentation

Ok, it works after I placed Start networked voice after begin play and connected it to run on server custom event not sure if it’s necessary. The voice quality seems pretty bad compared to how my microphone sounds on e.g discord. I’ll try this later with my friend and test how he sounds and how I sound from his end.

i can use the 4.26 version to this version 4.26.1?

Its been recompiled for 4.26.1 already

Hello,
I’m experiencing the following error in the logs (UE 4.25.4):


[2021.02.16-12.03.32:984][967]LogVoiceEngine: OSS: ReadLocalVoiceData: GetVoice: Result: Ok, Available: 0, LastCall: 0.000 ms
[2021.02.16-12.03.32:984][967]LogVoiceEngine: Warning: OSS: ReadLocalVoiceData: GetVoice failure: VoiceResult: Ok
[2021.02.16-12.03.32:984][967]LogVoiceEngine: Warning: OSS: Voice data error in ReadLocalVoiceData

And no voice can be sent from the clients that have this in the logs (most of the people connecting). The only clients that manage to send over the voice via steam are the ones that do not show this error (so far, only 1 PC out of the 8 that I’ve tried).

Is there a solution for this?

Thank you in advance,
r.

After some more investigation: if I set the mic threshold to -1 then the event *OnPlayerVoiceStateChanged *event gets correctly called on the Player Controller on the originating client and all of the other clients but the other clients still can’t hear anything.

Microphone works, is set as default, steam friends’ chat works, skype / hangouts / etc work fine.

Any ideas on how could be wrong? This happens on multiple clients, different machines.

The gamepad does not work when Steam is active. If I quit Steam, the gamepad works.
The gamepad works in PIE and Viewport. When I start the game via Launch, the gamepad does not work. I have to quit Steam and launch the game, then the gamepad will work.
What can i do?
UE4 Version ist 4.25.4

Can you give me link for 4.26.1

Its the same link, it overrides every hotfix.

I’ll change the text

I tried this but itd didnt work again when ı launch game its working but when ı package game its not working pls help me

Stupid, but at least short question. During installation should I create new C++ class with which module selected?

What do you mean not working? Steam doesn’t overlay?

If you are packaging steam to anything but development than you need to set your AppID up correctly. That is on the engines side, not the plugin, the plugin doesn’t spool up steam at all.

Hello.

I am trying to update the game settings of the session as soon as the game starts, so no one can enter the game.

But the variable never gets the correct value.

I am trying to update the session settings after creating the session. By the following blueprints, Get Session Settings returns the correct value, that should be meaning the player is currently in a session. However, when I tried to call Update Session, there is an error message “NO REGISTERED SESSIONS” displayed (shown as the second pic). Is there anything I missed to achieve session setting update?

What subsystem are you using and are you testing in editor or out of it? Technically that error should never display with an actual active session. Its a check against the session array not being empty before querying for one.

Packaged game (Windows 64) UE4.26.1 is not starting when advanced sessions plugins are enabled.

Anyone knows why?

Thank you <3

I want to make an online game, you will be able to invite your Steam friends in this game but it will require a different internet connection. how can I do it

I plan to use Oculus subsystem, while I am testing in editor with Online Subsystem NULL. I do not understand, if playing in editor is not having an actual active session, why could I use Get Session Settings successfully but not Update Session:( Thank you so much for your help.

Playing in editor creates a “psuedo” session for the separate windows to interact inside of. It does not actually add a session to the sessions array.

I am having a bit of a problem with getting a Steam dedicated server working. I can create a session and join via LAN across my network, but it doesn’t work online. I don’t have “Use LAN” checked. When I search for my session online I find 3 sessions, none of which is my session (according to Steam ID). I can find my server in the Steam server browser in both “Internet” and “LAN” tab. What’s wrong?