Download

Advanced Sessions Plugin

thanks will try that.

The main question though would be why the online session does not work and why it shows up as LAN. It might show up as LAN as both computers are in the same network, but not sure about that.

No, I test most of my remote servers on steam across two local computers. From your post I had assumed that LAN was your goal, not the side effect?

LAN was just a side question. Having trouble with Online session that shows as LAN.

Well I have the perfect article to sort this out for you and it will explain far better (and with better formatting) than I can in here.

I really should have linked to it a long time ago as questions related to it keep popping up.

TL;DR though, turn on Presence on the session.

http://www.aclockworkberry.com/ping-…ssion-results/

Ok fair enough I guess!

Is there anyone who knows how to check the mic of mine?
I can check which talker is speaking except me by is remote player talking.
However is local player talking with index 0 is not working.

Please help me nice guys!

Hello. I have one question. Does the UE4 network system allow creating sessions on in dedicated server on custom remote server(not Steam,Player host, etc.). I want connect to dedicated server which run on my remote PC(server) and create various sessions.That is, I want to run dedicated server on my remote computer and open sessions on it. Can I do this in one running instance of the dedicated server or will I have to launch a new dedicated server instance for each session. I looked at a lot of information but did not find an example of this , everywhere either creating a session as a player host, or an example of on Steam subsystem. I will be grateful for any lesson or tutorial related to this. As far as I understand, the Advanced Sessin plugin cannot help with this either, it creates sessions either as steam or as host.Thanks!!!

Dedicated servers are built into the engine yes, but you have to compile off of a source copy of the engine to do them.

You also don’t need any subsystem besides the default NULL to run servers but they won’t be “detectable” over the internet unless you set up a master server to provide and register the servers for you.

On the previous build (which didn’t have verbose set yet), I saw the following.

On boot:


[2018.11.27-07.22.04:454]  0]LogVoiceEngine: Error: STEAM: StopLocalVoiceProcessing: Ignoring stop request for non-owning user
[2018.11.27-07.22.04:454]  0]LogOnlineVoice: OSS: StopLocalVoiceProcessing(0) returned 0xFFFFFFFF
[2018.11.27-07.22.04:454] 0]LogOnlineVoice: OSS: Stopping networked voice for user: 0

...]

[2018.11.27-07.22.52:790][983]LogVoiceEngine: Error: STEAM: StartLocalVoiceProcessing(): Device is currently owned by another user
[2018.11.27-07.22.52:790][983]LogOnlineVoice: OSS: StartLocalProcessing(0) returned 0xFFFFFFFF
[2018.11.27-07.22.52:790][983]LogOnlineVoice: OSS: Starting networked voice for user: 0
[2018.11.27-07.22.52:790][983]LogOnlineVoice: OSS: RegisterLocalTalker(0) returned 0x00000000

I don’t do anything specific in my setup, do you know what I might look into here? Might it be related to the impossibility to mute remote players?

Thank you for your fast replys. Did not come to try it yet, hopefully next week.

Another player cannot join the session,why?

“JoinSession” node is not traveling to the Servers map,how to set?

Use Dedicated servers , UE4.21

[2018.11.30-22.09.50:989][108]LogOnlineSession: OSS: Join session: traveling to 192.168.1.8:0
[2018.11.30-22.09.50:990][108]LogNet: Browse: 192.168.1.8:0//Game/Map/Start
[2018.11.30-22.09.50:990][108]LogNet: World NetDriver shutdown IpNetDriver_0 [GameNetDriver]
[2018.11.30-22.09.50:990][108]LogNet: DestroyNamedNetDriver IpNetDriver_0 [GameNetDriver]
[2018.11.30-22.09.50:990][108]LogNet: UNetConnection::Close: [UNetConnection] RemoteAddr: 192.168.1.8:7777, Name: IpConnection_0, Driver: GameNetDriver IpNetDriver_0, IsServer: NO, PC: MMOPlayerController_C_0, Owner: MMOPlayerController_C_0, UniqueId: Null:SC-201807211748-16FD6DBD4C9BB17B244D08932E67A663, Channels: 19, Time: 2018.11.30-22.09.50
[2018.11.30-22.09.50:990][108]LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: [UChannel] ChIndex: 0, Closing: 0 [UNetConnection] RemoteAddr: 192.168.1.8:7777, Name: IpConnection_0, Driver: GameNetDriver IpNetDriver_0, IsServer: NO, PC: MMOPlayerController_C_0, Owner: MMOPlayerController_C_0, UniqueId: Null:SC-201807211748-16FD6DBD4C9BB17B244D08932E67A663
[2018.11.30-22.09.50:991][108]LogExit: GameNetDriver IpNetDriver_0 shut down
[2018.11.30-22.09.50:991][108]LogTemp: Display: ParseSettings for GameNetDriver
[2018.11.30-22.09.50:991][108]LogTemp: Display: ParseSettings for IpNetDriver_1
[2018.11.30-22.09.50:991][108]LogTemp: Display: ParseSettings for PendingNetDriver
[2018.11.30-22.09.50:991][108]LogInit: WinSock: Socket queue 32768 / 32768
[2018.11.30-22.09.50:993][108]PacketHandlerLog: Loaded PacketHandler component: Engine.EngineHandlerComponentFactory (StatelessConnectHandlerComponent)
[2018.11.30-22.09.50:993][108]LogNet: Game client on port 0, rate 10000
[2018.11.30-22.09.51:000][108]LogWorld: Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver
[2018.11.30-22.09.51:023][109]LogWorld: Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver
[2018.11.30-22.09.51:048][110]LogWorld: Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver

ok soooo,on open level you specify the level you want to open not your ip
on the join session don’t use a for loop but get the 0 index of the array and use that

Not to mention that the CreateSession there isn’t actually set to Dedicated Server…

Was able to get it working today.
First issue: We were passing 1 to CreateAdvancedSession::PublicConnections which must at least be 2 for listen server. Thats the reason it did not show up in the ServerBrowser at first (UsePresence = true).
Second Issue: We used the OpenLevel Blueprint-Node and passed in ‘-listen’ as option. The ‘-’ was to much.
Third Issue: The config file. With the following config we got it working.



[/Script/Engine.GameEngine]
!NetDriverDefinitions=ClearArray
+NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystemUtils.IpNetDriver")
+NetDriverDefinitions=(DefName="DemoNetDriver",DriverClassName="/Script/Engine.DemoNetDriver",DriverClassNameFallback="/Script/Engine.DemoNetDriver")

[OnlineSubsystem]
DefaultPlatformService=Steam

[OnlineSubsystemSteam]
bEnabled=true
SteamAppID=924770
SteamDevAppId=924770
GameServerQueryPort=27015
bRelaunchInSteam=true
GameVersion=1.0.0.0
bVACEnabled=1
bAllowP2PPacketRelay=true
P2PConnectionTimeout=90

[/Script/OnlineSubsystemSteam.SteamNetDriver]
NetConnectionClassName="OnlineSubsystemSteam.SteamNetConnection"

You might want to add this Comment to your CreateAdvancedSession function .


    /**
     *    Creates a session with the default online subsystem with advanced optional inputs, for dedicated servers leave UsePresence as false and set IsDedicatedServer to true. Dedicated servers don't use presence.
     *    @param PublicConnections            When doing a 'listen' server, this must be >=2 (ListenServer itself counts as a connection)
     *    @param bUseLAN                        When you want to play LAN, the level to play on must be loaded with option 'bIsLanMatch'
     *    @param bUsePresence                    Must be true for a 'listen' server (Map must be loaded with option 'listen'), false for a 'dedicated' server.
     *  @param bShouldAdvertise                Set to true when the OnlineSubsystem should list your server when someone is searching for servers. Otherwise the server is hidden and only join via invite is possible.
     */

Thanks again.

Yeah good idea

a player Creates a session
Another player cannot join the session,why?
“JoinSession” node is not traveling to the Servers map,how to set?
Use Dedicated servers , UE4.21

[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [r.SceneColorFormat:4]]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [r.DetailMode:2]]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [r.TranslucencyVolumeBlur:1]]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [r.MaterialQualityLevel:1 ; High quality]]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [r.SSS.Scale:1]]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [r.SSS.SampleSet:2]]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [r.SSS.Quality:1]]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [r.SSS.HalfRes:1]]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [r.EmitterSpawnRateScale:1.0]]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [r.ParticleLightQuality:2]]
[2018.12.05-06.28.20:267][177]sg.EffectsQuality = “3”
[2018.12.05-06.28.20:267][177]r.VSync = “0”
[2018.12.05-06.28.20:267][177]r.MotionBlur.Scale = “1”
[2018.12.05-06.28.20:267][177]sg.ResolutionQuality = “100”
[2018.12.05-06.28.20:267][177]r.ViewDistanceScale = “1”
[2018.12.05-06.28.20:267][177]LogConfig: Applying CVar settings from Section [FoliageQuality@3] File …/…/…/Client/Saved/Config/WindowsClient/Scalability.ini]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [foliage.DensityScale:1.0]]
[2018.12.05-06.28.20:267][177]LogConfig: Setting CVar [grass.DensityScale:1.0]]
[2018.12.05-06.28.20:267][177]sg.FoliageQuality = “3”
[2018.12.05-06.28.32:519][641]LogOnlineSession: Warning: OSS: No game present to leave for session (GameSession)
[2018.12.05-06.28.47:454][212]LogSlate: FSceneViewport::OnFocusLost() reason 0
[2018.12.05-06.29.02:834][795]LogScript: Script Msg: Found a session. Ping is 51

[2018.12.05-06.29.02:834][795]LogOnlineSession: OSS: Join session: traveling to 192.168.1.8:0
[2018.12.05-06.29.02:835][795]LogNet: Browse: 192.168.1.8:0//Game/Map/Start
[2018.12.05-06.29.02:835][795]LogNet: World NetDriver shutdown IpNetDriver_0 [GameNetDriver]
[2018.12.05-06.29.02:835][795]LogNet: DestroyNamedNetDriver IpNetDriver_0 [GameNetDriver]
[2018.12.05-06.29.02:835][795]LogNet: UNetConnection::Close: [UNetConnection] RemoteAddr: 192.168.1.8:7777, Name: IpConnection_0, Driver: GameNetDriver IpNetDriver_0, IsServer: NO, PC: MMOPlayerController_C_0, Owner: MMOPlayerController_C_0, UniqueId: Null:SC-201807211748-16FD6DBD4C9BB17B244D08932E67A663, Channels: 20, Time: 2018.12.05-06.29.02
[2018.12.05-06.29.02:835][795]LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: [UChannel] ChIndex: 0, Closing: 0 [UNetConnection] RemoteAddr: 192.168.1.8:7777, Name: IpConnection_0, Driver: GameNetDriver IpNetDriver_0, IsServer: NO, PC: MMOPlayerController_C_0, Owner: MMOPlayerController_C_0, UniqueId: Null:SC-201807211748-16FD6DBD4C9BB17B244D08932E67A663
[2018.12.05-06.29.02:836][795]LogExit: GameNetDriver IpNetDriver_0 shut down
[2018.12.05-06.29.02:836][795]LogTemp: Display: ParseSettings for GameNetDriver
[2018.12.05-06.29.02:836][795]LogTemp: Display: ParseSettings for IpNetDriver_1
[2018.12.05-06.29.02:836][795]LogTemp: Display: ParseSettings for PendingNetDriver
[2018.12.05-06.29.02:837][795]LogInit: WinSock: Socket queue 32768 / 32768
[2018.12.05-06.29.02:838][795]PacketHandlerLog: Loaded PacketHandler component: Engine.EngineHandlerComponentFactory (StatelessConnectHandlerComponent)
[2018.12.05-06.29.02:838][795]LogNet: Game client on port 0, rate 10000
[2018.12.05-06.29.02:845][795]LogWorld: Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver
[2018.12.05-06.29.02:869][796]LogWorld: Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver
[2018.12.05-06.29.02:898][797]LogWorld: Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver
[2018.12.05-06.29.02:922][798]LogWorld: Warning: SetActiveLevelCollection attempted to use an out of date NetDriver: GameNetDriver

Seamless travel? OnlineSubsystem? LAN/internet?

internet 和 Steam

seemless travel activated in all gamemode classes used?? Config files?

Who has project,internet and Steam ,or blueprint