Advanced Sessions Plugin

Hhmm weird, other functions seem to work. We are using a custom OSS so it might indeed be an issue from that side.

It is definitely an issue from that side.

When will you guys upload 4.19.1 updated version?

Can you please upload 4.19.1 updated version? Couse for 4.19.1, 4.19 version dont work…

? I already packaged and uploaded one for 4.19.1, i’ll re-package and re-upload though just in case

edit Re-packaged and re-uploaded, date on the other one appeared old, last upload must have failed.

Followup question: I can successfully get my friends list, and their names and avatars etc, and I can get whether they’re offline or away, but I can’t get the “Playing [Game name]” that shows up in the Steam friends list. I thought it would be in BPFriendInfo -> Presense Info -> Status String, but that’s always empty. Is this just not available?

[EDIT] nevermind, just found GetSteamFriendGamePlayed().

hey everyone! I have need solution…:)…
I join in the player in the session (JoinSession) when the pplayer Logout from Server I want the character not destroy on server, but stay on Server. Now when exit from Session the player destroy, I want stay on Server, how can solved this problem?


Im replacing OSS Null with Advanced Steam. Replaced all Find Session with Find Sessions Advanced and Create Sessions with the Create Advanced Session.

Using Steam works fine, can create a server and join to it with two different steam accounts. When I create a LAN server it seems to work and I can list it on clients. But when I press Join and go into Join Session, seems to reach it and print a string saying Success but never really joins the LAN Session and Open the Level. I created a new Event NetworkError and after 60 seconds I get a Time Out message.

What could be happening?

Thank you.

I have create dedicated server with advanced session but not see the server in the list when the player find on steam list the dedicated server why? I see the server dedicated only in the LAN…tk

When trying to build for Dedicated Server, it fails to produce item UE4Server-AdvancedSessions-Win64-Shipping.lib

This could most likely be an error on my end, but I’d like to see if the issue can be pinpointed down easily.

You need to build it yourself in visual studio, I can’t pre-compile for source builds.

Does it have a Steam Matchmaking?

Currently failing at using this to host/find a dedicated server.


Client (ignore the “Min Slots Available: 100”, it’s currently 0):

Currently, it constantly prints “Found 0 sessions”. I had more stuff in place with filters but I was worried I was filtering out my results. Turns out there was just 0 results regardless. Server is reporting the session is created successfully.

Edit: I’m guessing there’s an issue with my Find Sessions Advanced because I should be finding sessions from other people too, right?

Edit2: I’m launching both the server manually from the command line

I mean this one Steam Matchmaking & Lobbies (Steamworks Documentation)

The plugin doesn’t implement any of the match making features no.

Also the matchmaking “lobbies” are what UE4 uses for its steam listen servers to begin with.

Do you have the ports open for the dedicated server? Dedicated servers don’t use the NAT punchthrough that lobbies do.

No, but as I was running it locally and connecting with it shouldn’t be needed.

If I were to just execute a client (without launching a server) and run a “Find sessions advanced” using the Steam subsystem, shouldn’t I expect to see a number of sessions hosted on Steam using that appid all over the world? Or will it only find sessions created using the same executable that I have? I’m not sure how that works.

For now, I changed my subsystem to null and was able to get it working but I will eventually need to make it work with Steam. Also, sorry for the delayed response - I subscribed to this thread but wasn’t notified of a response.

Yeah this thread broke for notifications, I barely get any either.

The sessions are filtered out by the build ID (changes each packaging) by default with the subsystem, so no, you wouldn’t see them return, however it will log in the console a big list of rejected sessions if you don’t have a filter in place.

Within the latest version 4.19, packaging the project, doesn´t matter which one, developing or shipping, works only on win 64, but doesn´t package on win32.

Saying it´s missing “mspdbcore.dll”. I´ve tested within the previous version, and works, but i can´t decrease the version of my project, it´s too big.

I´ve tried to find on internet the solution, but didn´t find.

What i need to do to get it works?

Has nothing to do with my plugin, however there is already a bug report up for it.

Its an incompatibility with the newest visual studio version