Advanced Sessions Plugin

Makes sense.

Mordentral, can you add this fix to the 4.8 version please? I am sticking with 4.8.3 until they iron out a lot of the issues with 4.9 (as it seems many are).

What issues? I haven’t had any problems with 4.9. I’ll look into patching it, but pretty sure I’m participating in the game jam this weekend so don’t know when I’ll have time.

Check the forums, loads of people are finding bugs in 4.9, things that worked in 4.8.3 that are now broken. Many people are waiting for 4.9 to get updated with loads of fixes.

I’m stuck on 4.8.3 too because of the bug where the cooker ‘forgets’ about parent classes

Updated the 4.8.3 download to fix the update session function. The 4.8 version is still missing some not listed quality of life changes but it shouldn’t affect you using it.

I would suggest using the 4.9 version when it is stable for you though.

Thanks, much appreciated. Just started adding in some of the create session stuff, and am getting failure on create every time, I know it’s been a while since I fiddled with sessions, but I thought I had it all in place. I added the :


to the proper ini file. And it is a totally BP project. Oh well, have to run off to work, will look at it later, probably something silly.

Thankyou very much for updating the 4.8.3 version, it means alot!

For the MakeArray node, the output when using the ‘Make Literal Session Property …’ stuff is an Array of Session Property Key pair structures. I was trying to make a macro to clean up the BP’s a bit… I have what is below, but can not seem to find any key pair structure to set for the ‘outputs’ node so I can connect it. Is it possible?


Well no, that appears to have been an over site of mine, that keypair and one other struct were declared with USTRUCT() instead of USTRUCT(BlueprintType) so they are not directly accessible with blueprints.

I have changed them so that they are accessible on the 4.9 version and am uploading it. However the 4.8 won’t be updated until tomorrow (I download older versions and delete them after compiling for updates and I’m on the way out of the office).

I needed to re-upload 4.9 anyway for the 4.9.1 hotfix that just came out today.

Edit 4.9.1 version Uploaded

Nice, thanks, I will be trying 4.9.1 with my project to see how it goes as well, maybe they fixed most of the issues that came out in 4.9.

4.8.3 Version uploaded

Working like a champ.

When you get to the Update Session part be sure to use the AddOrModifyExtraSettings node, I made it just for updating arrays of settings so that it wouldn’t have to be done manually in Blueprint.

Maybe I spoke too soon, it works like a champ in the editor. When packaged it can not create session.

And when I do my ‘join’ to find sessions, it always returns that it did find a session, never returns fail, even though I don’t have one running. Ugh, guess I will be digging into that for the next few hours.

Well, not sure WTF is going on, but switched to normal create session and packaged and it worked… figured I would start changing options on Advanced create session, and clicked off Allow Invites, rebuilt and it creates them fine now. Dunno, will leave it off for now. With that set to on (allow invites) I was getting a travel error

It always returns success because it technically “finds” the other steam sessions that other people are hosting under the same ID, this is how their default implementation works. I debated returning failed if none of the servers were yours but decided to keep it consistent with their way of handling it.

If you check if the returned results array is > 0 right now it works as you expected it to, also if you use your own exclusive steam id it should work as expected as well.

Ah, am not using steam.

I am starting to think a lot of the troubles are 4.9.1 … now when I build I am getting an uable to find package for one of my game modes… it’s looking in the wrong directory. I think I am gonna have to drop back to 4.8.3… so annoying.

Very interesting, thanks for sharing :slight_smile:

mordentral, I managed to get steam in there, and working. Hosts a server. If I go to Steam and look at their servers list, should that show up if I filter for spacewar? (that’s what the 480 app id is from what I have read)…

Not seeing it up there, and not finding it when I do a search for sessions.