Download

Adding landscape kills performance in VR

I hope someone can help me out here. Adding a landscape to a level kills the performance (4.10 and 4.11p8).

First Person Example -> Smooth FPS on a GTX970
Add Landscape with default settings -> Performance is killed

Building lighting, setting most simple material to landscape, all this does not help.

anyone knows what I’m doing wrong?

render distance? quad count (landscape resolution iirc)? Lots of things could kill the performance… I would need to see your project to narrow it down

Yep it is the triangle count and the way tesselation works on it (it only considers x,y distance for tesselation clalculation and perhaps is happening on the CPU? not sure about that) you have to be more aggressive when LOD’ing it. The most important setting is to set the lod falloff to Square Root, I also set the LOD distance factor to ~2.0. Should get you back to 90FPS :slight_smile:

@SaviorNT
It’s the 3rd person template (New Project). I used it for testing.

@AtsK
Thanks, this setting helped to increase the FPS in my “real” project just enough to make everything smooth. However, in the 3rd Person Template these settings don’t help at all to raise the framerate :slight_smile: