Download

Add spline mesh component works, but reports an error

I have a spline which is movable, and a spline mesh component which is static being added to it.

This creates an error. However, the result is working as intended.

The spline starts at the player’s character and avoids obstacles on the way to the player’s cursor location in the world.

In order to do this I add spline mesh components to the spline and destroy them in a loop. In this way the static spline mesh components never need to move. They’re destroyed.

In order to remove the error I’ve set the spline mesh component to movable, but then they don’t appear in the world when called. I don’t know why, and I’ve tried resolving that issue separately.

I’ve also tried setting the spline itself to static as well, which also results in the mesh components not appearing in the world (or at least not where they’re intended).

The only combination of static and movable which works for my purpose here is to set the spline itself to movable and the mesh components to static, and then call them and destroy them as needed.

I am unsure if this is a problem in the engine, or if I’m not doing it right. That being said I do have a working version for my project now, and don’t really want to recode this section, but I would like the errors (i.e. warning in the editor) to stop.

I’m on 4.25 version.

Any suggestions?

Just a little bump here and to query;

the kind of warnings that the editor gives me are the ones in yellow, but seem more urgent perhaps because the pop-up dialogue appears when I end the programme in the editor.

It does not *look *as though this current setup is impacting on the performance of my game or causing any unwanted effects at all, but the editor warnings are making me feel as though I should be doing something about it.

Can anyone confirm that I can be overlooking these warnings? It feels like a bug in the engine to me (even though it certainly might not be), simply because everything is working as intended.