Actor flies through level like in level editor, instead of walking

As I had problems with exporting/packaging my project, I deleted one level that always crashed anytime I would just click on it in the Open Level Window. Because of that, I had to delete it through Windows Explorer, by deleting its .umap and .uasset files in the Content folder.

After I did this, I succesfully exported/packaged it, but moving through game wasn’t “walking” anymore, but “flying”, like when you’re in the level editor.

I would like to make my character walk normally again. the template i use is FirstPersonCharacter. When I look into its blueprints, on the red "InputAction Jump/Look Up/Turn/LookUpRate etc etc etc its says " WARNING! Input Axis references unknown Axis ‘’ for '’ "

(p.s. Gravity Scale is already set to 1.0 in CharacterMovement, I saw that advice somewhere, so it isn’t it)

I’m kind of new to Unreal so I’m not that good with these gamemode related blueprints so I didn’t understand the advices I saw for similar problems, where people said you should create your Axis and Action mappings - i couldn’t find them in the Settings.

You need to hook up your character. Make sure you pick your player & mode in the project settings. Also, make sure you didn’t delete any references by deleting from file instead of deleting the level in editor.

The best practice with cleaning up a game package is to migrate it to another created game file in the launcher and it will eliminate any unused stuff.

Also when you try to delete a level, it will show you all referenced BP’s and things in the Editor that you would need to un-hook for smoother delete.

Here is the Axis & action Input part.

Thank you soo much!! It worked!! Many thanks!!