Actor erases variables in another actor

I have an actor which in a exposed variable reference another actor. See picture where A_object is placed in the world and then referenced as REF:Active Object.

104016-exposed+variables.png

When i open the Blueprint for A_object and have my Actor selected i the viewport, make some changes and recompile all the references in my actor gets erased and looks like this.

104017-erased+exposed+variables.png

If I try and open the Actor or click on it the editor crashes, but if i Play the project and shut it down everything is back to normal.

The project is alla Blurprint and the Actor starts Custom Events inside the A_object.

Hi Alltvin,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to reproduce this on my end?
  • Is anything else affecting your actor variable or using it?
  • Can you show me a screenshot of where you are setting the variables?

Hi,

  1. I created a new project and migrated the issue causing actors, when repeating the scenario the same thing happen again.

  2. I tried to reproduce it myself without success. What I do is I have a Custom Event in the A_object which i call from the Actor. The reference variable for the event in Actor is set to Editable for the editor and I use the Pick Actor to choose the right A_object in the world.

  3. I don’t fully understand the question, but the A_object variable is set one time manually in the editor and never again.

  4. I don’t understand what you want to see. Can you explain futher?

Note:
I have manage to solve the whole issue though by removing the Editable A_object-variable inside the Actor Blueprint Graph, but the bug is still there if I reconnect it.

For the screenshots, I would like to see what your event graphs have in them. If you are setting the actor variable manually, can you show me what you are doing with the actor variable once it is set?

Hi Alltvin,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

hi,
sorry, been away for a while. I’m still experiencing the error and have been continuing to debug it on my side. The graph in my Actor where I reference the A_Object looks like this. If I remove the REF:Active Object everything works.

Inside A_Object i use the event like this.

Which variable is erasing? In addition, where are you populating REFActive Object and Active Interaction Point?

All exposed variables in the Actor A_Navigation is erasing as you can see in the two picturs in the main post above.

I’m populating them in the Main Viewport of the editor. I place the A_Object and the A_InteractionPoint in the world and then just select them from the list in each exposed variable (see first picture in main post)

Do you have any steps I can take to recreate this on my end. If not, can you send me a sample project this is occurring in? I have not been able to reproduce this on my end.

Hello Adam, I have finally found the bug!

The problem is with the standard input actions like keyboard-keys, mouse input and so on in combination with a direct blueprint communication between two actors.

I’ve a new small project with the bug if you want that?
If so how do I send it over?

I’m happy to hear you were able to find the bug. If you upload the project to google drive or dropbox and post a link here, I can pull the project from the link and take a look.

So here is the link:

Thank you for submitting a bug report. I have reproduced this issue and logged a report for it here. You can track the report’s status as the issue is reviewed by our development staff.