Actor doesn't start moving after upgrading to UE4.12


I upgraded to the 4.12 engine version (compiled, github repo source code).

In 4.10, my Actor starts moving forward.

In 4.12, after the upgrade, my Actor is motionless in the air.

I checked for the MovementComponent and all other properties (like Class Defaults) and all seems to be exactly the same.

The code also is the same, since I just did an upgrade without touching anything.

Just as a side note and feedback: since I started using this Engine, all I’m doing is trying to resolve engine-related problems. Incompatibilities with Visual Studio after upgrades, visual weird bugs resolved after restarting several times the engine, a bunch of crashes due to engine-related stuff.
I’m wasting lots of my time trying to solve engine issues, I barely touch my code.
I don’t even have the time to develop an algorithm.

As a developer, I’m struggling to make the engine work and not to make my algorithms work.
Frustrating guys. Seriously.

Hi ,

I tried to reproduce this by creating a new Third Person project in 4.10.4 and upgraded it to 4.12.5, but was still able to move the character around after the upgrade. Would you be able to provide some more information about this issue?

  • What template did you use when you first started your project?
  • Is the forward movement of your character automatic, or does it require input? How is your movement set up?
  • Did you upgrade your project directly from 4.10 to 4.12, or did you go to 4.11 first?
  • Are you able to reproduce this in a new, clean project, or does it only happen in your own project?

I actually had a similar issue after leaving Unreal open for 8 hours.

The Character projectiles would spawn but the gun wouldn’t animate and I couldn’t move.

After 30 minutes of checking the code for errors I fixed it by restarting my PC.


The problem isn’t about my Character, but a generic Actor that in my case has the role of a Grenade.

When I shoot a grenade in 4.10, it goes straight (as I coded).
In 4.12, it doesn’t move!

I have checked every Class Default property, every option in the MovementComponent and all the rest.

I compared those values between the two versions 4.10 and 4.12… apparently they’re exactly the same.

The grenade itself, though, works perfectly.
It explodes after a certain ammount of time, as it is supposed to.
The only thing it doesn’t want to do, is move!

For the rest, everything works.

Even my Rockets work and move properly! (Grenade and Rocket are two child-classes of one base class).

Did you upgrade your project directly from 4.10 to 4.12, or did you go to 4.11 first?

I converted from 4.10 to 4.12 directly (both versions are from github source code)

Oh well… I’ve had this problem for months… restarting isn’t enough for me

Hi ,

Sorry, I was not aware that you were having trouble with a projectile Actor. I did some more testing with projectiles, and still did not see an issue with movement after upgrading the project to 4.12.5. Would it be possible to get the header and source files for the grenade and base classes so I can match how you have it set up to try to reproduce the issue and find out why it is no longer working for you?

Hi thanks for your patience.

I managed to make it work by adding Super::BeginPlay() at the beginning of my child-class BeginPlay method.


Hi ,

I am glad to hear that you were able to get it working again. I am somewhat surprised that it worked without the Super call in 4.10. I don’t think anything changed in 4.11 or 4.12 that would have required the use of a Super call, but if your movement code is in the parent class it makes sense that adding the missing Super call would correct this issue.