Action RPG Inventory System

I doubt it’s by design there is no reason why the DataTable variable shouldn’t work eith nodes that take a DataTable input.

The person at Epic who got the task probably just half ***** it so they could finish the rest of their tasks quickly.

Thank you for posting a work around for those wishing to see ways to use the new variable.

I’ll try and write up a bug report for the Get DataTable Row Node not taking the new DataTable variable when i get a chance. Unless someone else can. I am still travelling and mostly on my phone this week.

The nodes always stated it only supports literal datatables, making me think it statically load the node selected table into memory which is probably why its setup like it is.

PIE:Error: Error SetInputMode_GameAndUI expects a valid player controller as target

I try to add character controller still have this error ?? also i add new Game and UI bp same error ??

It’s because epic changed that node recently to want a Playercontroller input.

If this is the node in the InventoryHUD you can just remove the node as the InventoryPlayerController sets this Input Mode already during the InitializePlayer function. Or simply get controller and plug it into the node as the error is asking you to do.

Yeah that done the trick :slight_smile:

Man i could sure use your help! Im trying to get these two assets to work together. Ive banged my head silly against this wall trying to figure out whats stopping them from working. I set it up like the panda video showed (and tried a bunch more ideas myself) but I cant seem to get it working. Any tips or pointers or anything would be sooooo useful!

Hi, how to use this system with 3D widget? It’s for VR game.

I will make a proper documentation in the future, that I will post in the Character Stats Kit forum ,were I explain what I did.

You would be my hero!!! I thought even after the tutorial didn’t work at all (For character stats) that it would be as simple as to putting the StatsUMG in the HUD, putting in an on pressed make visible, hook up the StatsUMG ref to the new ref from the Inventory Player Character and walla. But I get the widget to open fine, but it doesnt populate the information. Whether I follow the tutorial or add it to the HUD and make my own reference to the UMG and cast to it from the player character to hook into the setup node, i cant seem to get the darn StatsUMG ref to work.

Im really looking forward to that documentation or even a blip of a comment as to what direction I should look into!
Thanks so much Tylrin!

Well there will be awesome stuff and multiplayer trading with player without dropping on the floor or just delete if drag off the screen, anyways will be grate too for multiplayer addon to make dungeon loot system like in WoW

All of those features are fairly simple to add in on your own, just like adding in a character portrait :P.

Well i trying to get that but some how its hard for me to do gat character to look in equipment but its not updating items that i caring.
Also its hard to work alone…

when you OnRep your items you also need to set those on your preview character.


I went through the video tutorial and after this comes up whenever I try to press “I” to open the inventory.

It looks like the InventoryUI reference is null. This is set during the InitializePlayer function in the InventoryPlayerController. Please double check it’s reading a valid reference.

The InventoryHUD class loads the HUDLayout UMG widget and the InventoryPlayerController reads this from the HUD class to set the InventoryUI reference (of the HUDLayout widget) in the InventoryManagerComponent.

It is possible your same mode is not loading the InventoryHUD class. If you double check those two areas it ahould be easy to spot what’s causing the reference to not be valid.

If you are still having issues please email us at our support email so I can help you quicker.

I’m not using InventoryPlayerController. I have my own controller.

This is my begin play:

    2 (continuation).

So I realized now that it’s not even calling the begin play method of my controller class:

That print statement isn’t even being displayed. I checked the game mode though and it is using that bp.

Edit 1:
The constructor (construction script) seems to execute fine? Should I just do this initialization in the constructor instead? About to test.

Edit 2:
Same resulting error… the Inventory widget is null.

Edit 3:

I figured it out!! My controller is in a C++ version and the beginplay function wasn’t calling the superclass function. So evidently if you don’t call Super::BeginPlay(); in C++ it won’t fire the BP version of the function. I’m assuming this is the same for all events actually. Hopefully this helps others in the future lol.

Edit 4:
Now the problem is the same with the bag (B)

I got the equipment to open up by pressing (I).

Edit 5:

Nevermind, I’m dumb it was working after adding the Super::BeginPlay(); in C++
The Inventory was anchored to the right side of the screen so I couldn’t see it until I was in full screen mode.

If you merged it into the Epic Third Person Blueprint for some reason (no real need to since that template doesn’t really provide anything)
Make sure you deleted the placed character from in the level. Or you will possess this pawn instead of having your character spawning as it should.

It seems to me that might be what is causing your begin play not to be called.