Download

Action RPG Inventory System

if set parameter “Max loot items” == “Inventory size” - you see message error
18300e9af09b201f0f74ff4e819371f88d4cb089.png
2017-02-13_14-24-39.png

You sure? I have my max loot items to 4 and inventory size to 4 and no infinite loop.
Ensure that your actor that is derived from the loot_actor has a proper loot table, and that the probabilities of obtaining an item is actually possible.

Check out the functions “Loot_Actor>Get Loot List” which is called from “Loot_Actor>Get Random Loot Items” and if you are returning a proper local loot list, ensure as I said above, that the probabilities are in a realistic range. Check out the Loot_Common data table for the DropChance which is used in assigning items to the loot list.

Hope this helps.

What version of the ARPGIS are you using? A bug introduced in Unreal made the hover states not reset when a widget is hidden.

Please check in your InventoryPlayerController that you have applied this workaround fix until epic resolves the bug.

Yes as @Zeiten says you need to make sure the loot list has enough items in the list to be less than or equal to your max items specified in the loot actor.

Can you please send me a support email with screenshots of your logic so I can try to see why things aren’t working. I can’t think of any reason why that function would be failing in your project.

ActionRPGInventory merging with Character Stats Kit

Almost done merging the ActionRPGInventory System with the Character Stats Kit from Panda Studios.
The Inventory does no effect the stats yet , but I am still working on it.

Here is a Link to my video.

[video]https://youtu.be/tx6f0hwza94[/video]

Снимок.PNG
Some time game run and no respond to error. I see this error after 4.14.3 update. I dont edit nothing… Only parameter from first post, and see error. Back count to 3 - game play. But some time i see again this report error…

That fixed it tnx

I find ERROR. In my Loot_Hero table one item have “drop chance” == 0.001 in code minimal value 0.01. And in item list i have 5 items not 6

Ok great, I am glad you got it working.

Did some one made avatar to be shown at character items

https://s21.postimg.org/tf3lnytlx/Untitled.png

The ARPGIS is compatible with 4.15 and can be upgraded to 4.15 from previous versions.

I will be submitting an update for people who are creating a new 4.15 project that makes some changes based on the new addition of the DataTable variable (Epic finally added it) as well as enabling window drag be default again. As usual I will include the notes for the changes when the update is submitted.

I just tested and its working fine with 4.15

I wouldn’t bother the Get Data Table Row Node can only be used with literal datatable variables probably by design, the only other method which gives you a list of loot tables to select from is this approach below, i still think its better than Overridden the loot function.

I doubt it’s by design there is no reason why the DataTable variable shouldn’t work eith nodes that take a DataTable input.

The person at Epic who got the task probably just half ***** it so they could finish the rest of their tasks quickly.

Thank you for posting a work around for those wishing to see ways to use the new variable.

I’ll try and write up a bug report for the Get DataTable Row Node not taking the new DataTable variable when i get a chance. Unless someone else can. I am still travelling and mostly on my phone this week.

The nodes always stated it only supports literal datatables, making me think it statically load the node selected table into memory which is probably why its setup like it is.

PIE:Error: Error SetInputMode_GameAndUI expects a valid player controller as target

I try to add character controller still have this error ?? also i add new Game and UI bp same error ??

It’s because epic changed that node recently to want a Playercontroller input.

If this is the node in the InventoryHUD you can just remove the node as the InventoryPlayerController sets this Input Mode already during the InitializePlayer function. Or simply get controller and plug it into the node as the error is asking you to do.

Yeah that done the trick :slight_smile: