Able Ability System Info and Support Thread

Able v2.29 Submitted:

is there an easy fix that the content browser for selecting the preview? Often when I select the class as character - hes not suggesting me any blueprint for preview.
STILL a problem with blend in and blend out for anim montages on play anim as montage. or somehow Im using it wrong. in order to play in a specific slot you should feed anim montage as input animation however as its “play as dynamic montage” it should take anim instance so maybe that’s what Im doing wrong? still… in any combination - not working blend out. 4.20 newest update.

Hi AngelV,

I think you’re talking about multiple issues here, so I’m going to split them up and respond to each.

Try turning on “Show Internal Classes” and see if that pops it up. I’m still not happy with the Preview Selection workflow, so it’s something I’m actively looking at how I can simplify things right now. Just to verify, this isn’t something that broke, it’s something that you would like to be easier?

You should be passing in an AnimMontage (it just happens to inherit from AnimInstance) if you are using Dynamic Montages. Other than that, everything is handled on Epic’s end (I’ve even exposed the slot name used for the Dynamic Montage if you want to change that). If you want to blend in/out Anim Instances dynamically, I would suggest using the “Ability Animation Node” option and just setup the Ability Animation Node within your Animation Blueprint:

On the first topic… Unfortunately in 4.20 its broken. it takes forever to load any object into the browser and loads nothing. However I can make abilities without checking preview if I know what im doing :wink: I will check the “show internal classes”
I am passing anim montage to montage slot, yet still it happens. As I pass the montage it uses the slot already in the montage as it should. It should blend-out as it does on montages used in blueprint right? the effect should be exactly the same?
As for the animation node - I had problems with bad read of “isrunningabilityAnimation” and I had problems with using the node outside of a state machine. or when I used it in a state machine inside a state machine.
I just don’t get why the montage blends out dirty :frowning:

And just on the margin: I love your plugin. I suggest it to everyone. its a solid 5/5. I was using it to run pickups, inventory management, and it helps manage multiplayer so much, as well as fragment code and allow to utilize “is playing ability” instead of “anim instance - is playing montage”. The use cases are limitless!
But this one thing is still bugging me out somehow. :smiley:

Hmmm, Let me play with things over the weekend. If you have a sample project setup that I could reference, send me a PM or such with a link and I’ll use that specific project to see what it could be.

EDIT: Also, which Blend Out time are you trying to use? The one in the Montage itself, or the one you set in the Ability with the Play Animation Task?

I have the montage and ability use the same blend in and out just in case. it blends out, but on the last frame the entire pose kindof… resets.

Resets as it goes back to the animation beginning and then stops (jerking motion basically)? Or your character goes into a T-Pose?

hard to see if he tries to go into T… looks like he forgets the state he has of the animgraph. like the anim instance is being set again for anim blueprint or something.

I apologize for not reading through the 50+ pages of text here. Just curious if this will have Niagra support?

Excuse me, my engine version is 4.17. How do I install this plugin?


I have a small question. It seems at the end of the PlayAnimation task, or when the skill ends, it seems to reset all animation montages. Is there a way to change this from happening? The reason I ask is because I have setup a combo system using Ability Branching. The animations are timed perfectly so that the 2nd part of the combo begins where the 1st animation ended. The problem I’m having as that on the first frame of the branch, the ability is stopping all montages from playing, then the next frame the 2nd animation starts playing. This causes the character to enter the Idle animation for one frame between the 1st animation and the 2nd animation and it looks really bad. What can I do to resolve this?



I have reinstalled this plugin again recently.
I have this Bug / problem with Play Animation task.

When I either select Null or select an animation, I would like to change animation and see different ones.
When i do this, it does not change to the animation in scroll down.
Please can you have a look into this. Thank you

Are you saying you would like it to instantly play the animation while you are scrolling through? Or you simply aren’t seeing any animation play after you select one and hit Play?

EDIT: I’m also working on the 3.0 update which will have some very cool things hopefully people enjoy. Hoping to get it out before the New Year.

Hi matt, yeah the anims just wont change. Tried everything already. Even started new project. I have to delete play anim and add new one.

What sorta new features you adding?
Cant wait.
This is my main ability system for my game now?

You may need to save the ability before the Animation will play (but that should happen behind the scenes when you go to play it). You can turn on the “Verbose” option for that task and see what Animation it says it’s trying to play. I’d be curious to see your output as I’ve never had that issue reported to me.

I’ll share more on 3.0 as I’m ready. It’s turned into a rather meaty update, and I think people will enjoy it.

Hi matt, Since i cant seem to explain this and you have not seen this error before, I have just made you a video to show you the issue. :slight_smile:

Can you Check your E-Mail as i will email you the video over of the error.

Thank you


I have emailed it over to [EMAIL=“”] address. Cant remember your other address and cant find it

Cheers Matt


Perfect, Thanks Jesse!

So, in your video, I never see you hit the “Play” button in the toolbar at the top once you select your Animation (which causes the Ability to play itself). Automatically playing the animation after being selected could be done, but it could be a bit weird because people may not want to automatically play the ability just because you swapped an animation.

I didn’t get any audio in your video, but I assume that’s your issue? Or am I misunderstanding?

Have you got fb or discord??
I did press play

Does not change at all so deffo something wrong stays as same anim. :frowning: