AActor with UChildActroComponents defined in C++ crashes the Editor

Happy New Year, guys.

Hope you aer enjoying your holidays, because here I bring you a bug, and hope you will fix it in 4.14 it is quite annoying.
I have a c++ actor with some UChildActorComponent in it, I blueprint I subclass from it one blueprint, to setup ChildActor class, and there is another blueprint, which subclasses from that first blueprint. I already created one map, and somehow added actors of that blueprints there. And now, whenever I open that map, Unreal Editor crashes.
If I create new map, and try to add that blueprint there Unreal Editor crashes again.

Here is the project with that bug reproducible link text

If you open NewMap editor will crash. If you open NewMap2 and drag bp_childfeaturepoint there, editor will crash with the same error.
Not sure why it does it, Maybe there is a bug in my c++ Actor, because if I add childactorcomponents in blueprint everything looks normal.

[2016.12.29-13.21.43:445][829]LogWindows:Error: === Critical error: ===
[2016.12.29-13.21.43:445][829]LogWindows:Error: 
[2016.12.29-13.21.43:445][829]LogWindows:Error: Assertion failed: !HasAnyFlags(RF_NeedLoad|RF_NeedPostLoad) [File:D:\Build\++UE4+Release-4.14+Compile\Sync\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectLinker.cpp] [Line: 102] 
[2016.12.29-13.21.43:445][829]LogWindows:Error: Detaching from existing linker for D:/MyProjectCA/Content/BP_ChildFeatrurePoint.uasset while object TargetPoint /Game/BP_ChildFeatrurePoint.Default__BP_ChildFeatrurePoint_C:TargetPoint.None needs loaded
[2016.12.29-13.21.43:445][829]LogWindows:Error: 
[2016.12.29-13.21.43:445][829]LogWindows:Error: 
[2016.12.29-13.21.43:445][829]LogWindows:Error: KERNELBASE.dll
[2016.12.29-13.21.43:445][829]LogWindows:Error: UE4Editor-Core.dll!FOutputDeviceWindowsError::Serialize() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:103]
[2016.12.29-13.21.43:445][829]LogWindows:Error: UE4Editor-Core.dll!FOutputDevice::Logf__VA() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\misc\outputdevice.cpp:68]
[2016.12.29-13.21.43:445][829]LogWindows:Error: UE4Editor-Core.dll!FDebug::AssertFailed() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\core\private\misc\assertionmacros.cpp:332]
[2016.12.29-13.21.43:445][829]LogWindows:Error: UE4Editor-CoreUObject.dll!UObject::SetLinker() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectlinker.cpp:102]
[2016.12.29-13.21.43:445][829]LogWindows:Error: UE4Editor-CoreUObject.dll!UObject::BeginDestroy() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\obj.cpp:651]
[2016.12.29-13.21.43:445][829]LogWindows:Error: UE4Editor-CoreUObject.dll!UObject::ConditionalBeginDestroy() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\obj.cpp:752]
[2016.12.29-13.21.43:445][829]LogWindows:Error: UE4Editor-CoreUObject.dll!StaticAllocateObject() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:2376]
[2016.12.29-13.21.43:445][829]LogWindows:Error: UE4Editor-CoreUObject.dll!StaticConstructObject_Internal() [d:\build\++ue4+release-4.14+compile\sync\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:3206]

Hey -

If you’re having problems using Child Actor Components, the crash you’re seeing is likely related to this issue: Unreal Engine Issues and Bug Tracker (UE-39323) . As shown on the report, this issue should be fixed for 4.15. You can download the 4.15 branch from Github to see if the issue is fixed for you there. If you continue to see this crash after 4.15, feel free to comment on this post to reopen it for further investigation.

Cheers

Nope, it still crashes at NewMap open
Now only the crash window look different )

How exactly did you create your child blueprint in the sample project? I ask because I tried creating a blueprint of the FeaturePoint class by right clicking in the content browser and selecting Blueprint Class and choosing FeaturePoint from there. I then created two child BPs of my new class: 1) using the same method as when creating the parent, choosing my parent class instead of Feature Point and 2) by right clicking on the parent class and selecting Create Child Blueprint Class. In both cases I was unable to get the project to crash when attempting to open either child.

Additionally, after commenting out the added code in the FeaturePoint class, I noticed that your child blueprint has an empty custom function as well as an empty event graph. After deleting these and readding the code, I was then able to open both your child blueprint class as well as the NewMap level. Please let me know if this information helps.

Hi ,

I think when you create BP’s you are not setting Child Actor class there. If you set it to Target Point and compile then strange things start to happen.

Empty graph and function are not required i think, I added them just to have BP switch to full mode by default.

I double checked that the newly created parent blueprint had TargetPoint and CameraPoint components’ child component set to TargetPoint. After saving/restarting the project / adding new child BP to NewMap2 I still did not get a crash outside of your original child blueprint. Can you explain exactly how you created your child blueprint? Also, please let me know if commenting out the added code of FeaturePoint class and removing the empty function/graph from your child blueprint, then uncommenting the code has any affect for you.

Hey -

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.

Cheers