Download

A Feature Level 5 video card is required to run the editor.

I download Unreal Engine in some versions,but when i open,a error appear,i try to download some old version(4.19.2)and the same error…
When i try a OLDER version,like 4.3,and nothing happen, i can use this version…

… you probably need a newer video card. What do you have?