Download

A couple Terrain Painting issues (version 4.7.2)

First off Shift Left Click won’t erase what I’ve painted. Is there a known cause for this? I can’t seem to find one.

This one I have found the other threads that explained a fix(ish) but I can’t get it to work. Plus not being able to erase makes it a bit worse.

Any way it’s the Paints the whole square bug. I’ve done what everyone suggested and tried to paint using each layer. The shaders compiled. But still paints using the whole square.

I am following this tutorial: https://www.youtube.com/watch?v=tsXVP0fykBM

Trying to use the basic material shown in that video.

landscape_material.PNG

cb1a2b3341e01609ecc46cd0fbee8d0e85426f1e.jpeg

In the terrain image it seems to half way work some times.

Any help or info on this subject is greatly appreciated.

I’ve tried the info on these posts:

Post 1
Post 2
Post 3

Thanks,

Ian

Have you already painted onto the entire terrain with one layer? -> after that it should work :slight_smile:

That is such a pain though painting it entirely with one layer just to get past this issue specially when the landscape is large.
Speaking of it because I did that for my WIP landscapes, I hope the issue would be solved soon.

Ya I tried painting the entire thing but it was still weird.

also I can’t delete anything because the shift left click isn’t

Im using This method Its more like in UDK as far as i know. works well with no text coord. Normal layer nee to have exactly the same name as the color/base ones.
the only issue as i put it there is when you first create the material you need to create an layer info a little “+” sign where you chose layer you want to paint.
And if you put nothing as the first base you get black terrain until you paint the first layer you want

Btw you cant undo paint made on terrain you need to paint again with another layer previous or another one you want. Im using 1.7.2 too

Hope it help a little at least

I’m having similar issues. As soon as I add a normal connection to the normal input for the material…all those areas that are painted turns black.

I’m trying something similar to this: (scroll to the bottom)

If I disconnect the normal, it seems to work ok.

Well, their own walkthrough says you should be able to delete what you’ve painted

W8KflVM.png

I’ll have to try your material.

UE4 does seem like a beast. I don’t have the fastest computer in the world but I can run Unity without any problems. I’m wondering if my computer just isn’t up to UE4. Even with a simple scene with a small terrain and one actor (few cubes) it lags out even on the lower settings.