Download

A couple of odd problems

hi,

I have started having a couple of very strange issues, first I just tried starting the launcher a few times and it gets stuck on the “checking for update” screen witch I got round by going offline, the second problem is every time I open the editor (version 4.0.2 or 4.1) and then close the editor its still running.

here’s a pic showing what I mean better.

the launcher does it as well but I just checked the task manager again and the launcher has now gone from the list, the really weird thing is that the pic is of the “background tasks” section of the task manager, I checked to see if any other programs/apps have the same thing happen and they don’t.

is anyone else getting the same thing?

–EDIT–

forgot to say the only way I’ve found to get rid of it is to restart my laptop.

Howcome it is letting you start the launcher if it is already running? Weird.

I had multiple editors running in the background issue only once about a month ago but it closed itself after a while. Apparently it took the editor a bit longer to actually shut down for some reason. I’m guessing those are Windows related issues though. I havent formatted the computer for a year now so it doesnt surprise me to have such glitches every once in a while.

well when I first start the launcher it appears in the “apps” section of the task manager but when I close the launcher it shows up in the “background tasks” section and every time I close the launcher it stacks up as shown.

a weird update, after I turned my laptop on today I realized it was very sluggish so I opened the task manager and the memory was stuck at 84%, I looked through list of processes and there were no UE4’s shown but then I clicked on the “details” panel of the task manager and saw this

Its fairly obvious why my memory usage is so high, I haven’t even started UE4 today so I don’t know why they are all still running, I am going to try uninstalling/re-installing and see if that works witch is something I didn’t want to do.

final update, because the launcher went dodgy it wouldn’t let me uninstall either version of the engine and because the engine was always running I couldn’t forcibly uninstall it so I had to rip it off my hard drive by opening the binaries folder and changing the names of some of the dll files and restarting my laptop witch meant UE4 couldn’t run at all and then I just deleted it from my hard drive (it left me no choice:)). after I finally got it off my pc I reinstalled the launcher and version 4.0.2 witch worked fine until the launcher updated a little while ago and now it wont load from the launcher but does if I click on the project. I also tied 4.1 but that wouldn’t launch at all. I’ve ended up uninstalling 4.1 and the launcher, I made a shortcut on my desktop to the 4.0.2 editor so now it works just like UDK (click on the shortcut and the engine loads straight up, no hassle;)).

to be honest having it start up like UDK without the launcher badness or the dodgy 4.1 its so much better, so problem solved-ish:D

A little late but i have had this issue, it affect my main running unreal thou, some kinda crazy bug before i save or rebuild i have to delete those or my game crash so i work with my task manager open, when i ready to save i go in and delete the extra processes, or when i ready to rebuild lighting i do the same.

good thing is my main unreal that i use load into apps while the bug ones load into background apps so i never had the problem of closing out the wrong one LOL

I tried ending the process but I kept getting a message saying “Access Denied” so I couldn’t end it, that’s why I had to get rid of it:p, anyway UE4 shouldn’t be doing it in the first place, I hope they fix it soon.

Hi smokey13,

Could you post this to the answerhub at http://answers.unrealengine.com so we can track this and provide assistance to you? Thank you!

ok, I have posted it on the answerhub (I put it in the bug report section)UE4 keeps running after being closed - UE4 AnswerHub but as I really don’t like that place and didn’t want to write everything again I just put a link to this thread, oh and its nice to see pasting a link on the answerhub now works.