Download

40 fps feels like 20

Hello,

I am running into some issues when running the game bellow 60 fps.
At 60 fps everything is very smooth, but as soon as I hit 40 fps I can see a lot of hickups, it’s not smooth anymore but I have never had this issue before in a game where 40 fps feels like that, it feels more like what I experienced when playing some games at 20 fps.

Is there something to do to reduce this feeling ? I am not even sure the problem is related to rendering, might very well be the physics engine not stepping every frame while would cause this feeling even though I get 40 fps.

Thanks,
Max

Are you sure it’s running at 40fps? You should not even notice a drop from 60 to 40. (Well… I never do.)
Sometimes the thing that tells me the Fps gets screwed up. Restart the engine and hope for the best.
Also, How big is you’re scene? Are you doing everything possible to make the map smaller? (For how much detail is show.)

Yes I am using Fraps to see the FPS.

It happens even with a packaged build, in the engine I get 60 FPS but the video settings are a lot lower.

My scene is just a simple BSP cube with the third person character on it, I don’t think there is anything I can do to optimize the level itself.

Turn up/down change your fps smoothing in project settings. Sometimes it (unity)s up and 60 fps feels like a studdery mess.

(I have to use unity instead of curse words because forum policy, epic pls)

Thank you so much disabling FPS smoothing did the trick, it’s now very smooth :stuck_out_tongue:

Just a small tip. Press ~ and inside the console type stat fps. It is a lot easier than using Fraps. :slight_smile:

Good to know, thanks :slight_smile:

Pretty sure you get a message when you load the editor with fraps running, telling you not to use fraps :stuck_out_tongue:

Fraps slows it down so bad.