4.9 crashes randomly when compiling a big BP or clicking Play after doing so


I ported one of my projects from 4.8 to 4.9 and it made my work filled with crashes. 4.9 crashes randomly (but very, very often) when compiling a big BP or clicking Play after doing so. I work on such BP, with a lot of variables and functions and haven’t got such problems earlier with it (other, much smaller projects in 4.9 don’t cause something like this). Now every time I try to compile it or PIE I can only hope it won’t crush. Saving beforehand helps to preserve my work, but it’s very frustrating, as you can probably imagine. :wink: I don’t know how to help you narrow the problem in any other way than sending you my BP, but I must do it with a private message. Just let me know where and who should be a recipient.

PS I’ve already sent a few reports by the interface that shows up after crash. Today tried with 4.9.1 but nothing changed.

Hi Nox_A15,

Thanks for submitting the report through Crash Reporter. Next time this crash occurs, please copy the Machine ID before hitting Send, and post it in a comment here so we can look it up in our system. Additionally, please zip and attach the logs from the project’s \Saved\Logs folder. That’ll give us a place to start investigating, and we may ask for the BP later. Thanks!

Hello Ben,

No problem, here is the ID and the Logs folder:



PS This time it crashed after hitting Play and worked quite long without crashing in the BP editor. But that’s probably in the logs.

Thanks Nox! Looks like we have a couple of other crash reports with similar call stacks, and a larger number with the same error message. I’m going to enter a bug report for these, but it would be extremely helpful to have a copy of a project in which this occurs. If you don’t mind, please zip up and upload your project someplace like Dropbox or Google Drive and send me a link via PM on the forums:


And let me know which BP in particular seems to be causing the crash on compile or PIE. That way I can give the devs something to reproduce the issue with.


I though this was normal behavior xD

Kidding aside, in my personal experience this “IsA” BP crash issue is exacerbated when working with Widget Blueprints and their classes. Maybe that’s only a perceived pattern, but every time I hit compile in a Widget Blueprint I hold my breath anticipating the crash.

We have another bug open that has that same basic error involving widgets, I believe. Different call stack, though, so I’m not sure.

I’ve just sent you the link and forgot to mention about placement of the BP, so there are two messages in total. :slight_smile: Look for “Test Project for 4.9 BP Crashes”.

Hey Nox,

Thanks for the project! I was able to reproduce the crash in 4.9.1, but I can’t seem to locate the specific reason for the crash. I’ve created a bug report and linked your project for the devs to look at (UE-21255). I suspect it’s related to another similar call stack which we also have reported (UE-20750), so hopefully we’ll find a solution soon. I will update this post when I see any progress.

I unfortunately do not have a workaround at this time, but as I have time I’ll attempt to find one for you so you can submit to marketplace. I’ll post here if I find one.

I was not able to reproduce the crash in 4.11. The most likely fix is this commit.

Thanks for sharing your project with us, it’s a huge help.

No problem, glad it helped! :slight_smile: Thank you for looking into it! I will test it out when the fix will make it to the next Preview build.