4.9.2 & Ark Dev Kit v217.0 Crash On Launch / Epic Launcher Crashes Randomly

I’m trying to get UE4 up and running to being playing around with UE4 as well as Ark Dev Kit mods. Currently I’m running into two main issues.
System Specs:

  • Windows 10
  • GTX 970 (Newest Drivers)
  • Stable Overclocking 4.5ghz

(1) Epic Launcher Randomly Crashes - It’s similiar to the issue described here and I’ve tried the following things to fix it:

  • Ran as adminstrator
  • Updated Drivers
  • Restarted PC
  • Unistall and Reinstall both Mod Pack and UE4.9.2
  • Reinstall the launcher

Debug information is as follows:
[1006/223234:WARNING:raw_channel_win.cc(473)] WriteFile: The pipe is being closed. (0xE8)
[1006/223234:WARNING:channel.cc(549)] Failed to send message to remove remote endpoint (local ID 1, remote ID 1)
[1006/223234:WARNING:channel.cc(549)] Failed to send message to remove remote endpoint (local ID 2, remote ID 2147483648)
[1006/223234:WARNING:raw_channel_win.cc(473)] WriteFile: The pipe is being closed. (0xE8)
[1006/223234:WARNING:channel.cc(315)] RawChannel write error
[1006/224911:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
[1006/225753:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
[1006/225840:WARNING:raw_channel.cc(210)] Shutting down RawChannel with write buffer nonempty
[1007/004802:WARNING:raw_channel_win.cc(473)] WriteFile: The pipe is being closed. (0xE8)
[1007/004802:WARNING:channel.cc(549)] Failed to send message to remove remote endpoint (local ID 1, remote ID 1)
[1007/004802:WARNING:channel.cc(549)] Failed to send message to remove remote endpoint (local ID 2, remote ID 2147483648)
[1007/004802:WARNING:raw_channel_win.cc(473)] WriteFile: The pipe is being closed. (0xE8)
[1007/004802:WARNING:channel.cc(315)] RawChannel write error

(2) UE4 & Ark Dev Kit Crash with the following Error
MachineId:4C04817C4FC6729755B69BB3F4CED191
EpicAccountId:2c080fa03fa342ca90c4003caf96891e

Unknown exception - code 00000001 (first/second chance not available)

"Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.9\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11Util.cpp] [Line: 259]
D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.9\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D

UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\core\private\misc\outputdevice.cpp:354]
UE4Editor_D3D11RHI!VerifyComRefCount() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\windows\d3d11rhi\private\d3d11util.cpp:259]
UE4Editor_D3D11RHI!FD3D11Viewport::Resize() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\windows\d3d11rhi\private\d3d11viewport.cpp:199]
UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::ConditionalResizeViewport() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:325]
UE4Editor_SlateRHIRenderer!FSlateRHIRenderer::DrawWindows_Private() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\slaterhirenderer\private\slaterhirenderer.cpp:633]
UE4Editor_Slate!FSlateApplication::PrivateDrawWindows() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:1200]
UE4Editor_Slate!FSlateApplication::DrawWindows() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:927]
UE4Editor_Slate!FSlateApplication::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\slate\private\framework\application\slateapplication.cpp:1441]
UE4Editor!FEngineLoop::Tick() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\launch\private\launchengineloop.cpp:2461]
UE4Editor!GuardedMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\launch\private\launch.cpp:142]
UE4Editor!GuardedMainWrapper() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
UE4Editor!WinMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.9\engine\source\runtime\launch\private\windows\launchwindows.cpp:200]

I’ve copied my “dxdiag” system information and attached them.
link text

Some more context to each of the issues:

(1) This happens after sometime using the app. If I open it it’s fine but if I minimize it to the bar and maxmize the application it stops responding with and closes.

(2) Both editors open and load 100% of the way through but after about 5-10 seconds of navigation it seems something trys to load and it crashes with the error listed above.

Any insight with the issue would be great!

Thanks

Fixed the first issue. Ran with the “-OpenGL” command and installed DX11 drivers.

Still having issue with (2). Having varying crashes but loading the Ark project upon moving my cursor from the Viewport to any other part of UE4 editor it gives me the error shown above and crashes. Running normal UE4 gives the same error after loading is complete and any window pops up.

I’ve decided this is most likely a result of using Windows 10 which hasn’t been fully tested and supported so I’ll be doing a downgrade to 8.1 which doesn’t utilize Dx12 backwards compatability to run Dx11. Hopefully this will work but I feel as issue (2) is related specifically to Windows 10.

Thanks for the Reply . I’ll continue going forward with a stable version until this is fixed.

Hey halfblind,

I tracked down your crash in our system and it does appear that every other instance of this crash has been from users on Win10. It is entered in our system as UE-21504 and is currently assigned to an engineer’s to-do list.

-.

Any new about this?

I haven’t tried with windows 10 again since there has been recent driver updates since I’ve been busy. I can give it another crack but I’d recommend going to windows 7 or 8 as they are listed under support OS’s for UE4.

As long as you’re getting the same callstack, this is still under investigation.