[4.8p3 - Win] Can't build engine from GitHub source

I’ve been trying to build GalaxyMan’s Nvidia Gameworks merged branch (Github Link) - Here is the Gameworks UE Integration thread on the Unreal Engine forums

Currently, I have tried other official branches and am yet to have one build successfully, so it doesn’t seem limited to the Nvidia branches, official or not.

I’m extremely new to Visual Studio, so it’s very likely that I am missing something or doing something wrong. However, I have followed the readmes, guides, etc on the topic and still am yet to have any luck getting the editor running.

VS Build Failed Screenshot

http://puu.sh/i9LVs/df2f60d624.png

Trying to launch the UE4Editor.exe pops up with an error mentioning “UE4Editor-UnrealEd” as being missing.

If there’s any other information that may be of use, I’d be happy to provide it since I have undoubtedly left a lot of important information out. Haha.


Relevant System Specs: Intel Core i7-5960X - 16GB Crucial DDR4 2133Mhz - SLI GeForce GTX 780 Ti - 120GB Samsung 840 Evo SSD

Other Info: Windows 8.1 Professional x64 - Visual Studio 2013 Pro

Hey Brandonsmule-

I just want to confirm that when you download the zip file from GitHub and unzip it to your computer, that you’re then following these steps.

First run Setup.bat followed by GenerateProjectFiles.bat.

Once those have both finished you should then be able to open the UE4.sln file and build the engine which will take some time.

When it completes you can navigate to the Engine/Binaries/Win64 folder inside where you unzipped originally.

In the folder you should be able to find the UE4Editor.exe and double click to launch the engine.

Let me know if you’re able to do this or if you run into any issues in this process.

Cheers

Doug Wilson

I do, indeed. I’ve followed the steps thoroughly yet it still won’t successfully build. =/

As for launching UE4Editor.exe from the binaries folder, it just gives me a popup error mentioning UnrealEd.dll being missing


Edit 1: In the middle of attempting to build it again, found that my VS120CommonTools linked to a non-existent directory. (Update: Didn’t help)

Hey Brandonsmule-

When you downloaded the engine from GitHub did you download the 4.8 branch or specifically the 4.8 preview 3 tag? Re-downloading from GitHub may also help if something happened during the initial download. If you are using the preview 3 tag then you may want to try the preview 4 tag instead.

I’ve tried the latest release branch, 4.8, as well as various Nvidia Gameworks forks. None build successfully, and they all give the same 3 errors in the screenshot from the original post.

Hi Brandonsmule,

Error C1083 typically means that the Windows SDK is not installed, or is installed incorrectly. Could you check and make sure you have that installed correctly?

Tim

Hi Brandonsmule,

We have not heard back from you for a few days. Do you still need help with this issue? I will be marking this post as resolved for internal tracking purposes, but if you still need any help, please feel free to add a comment and re-open this post.

Tim

Thank you, I forgot to update this post. Your answer is correct and the issue has been resolved, somehow a ton of the files in my Windows SDK installation went missing.