[4.8P1] my collisions no longer work for a spline mesh component

BUG: 4.8 preview my collisions no longer work for a spline mesh component.

I have a spline that has a (tube) mesh component (complex as simple, double sided geometry) with various spheres inside the tube, they spheres collide with each other but not the tube. On 4.7.6 they all collide as they should but upgrading that project to 4.8 and they stop colliding with the walls.

This could be related to the changes you have made for convex collisions however i am using complex as simple which does not require a collision mesh.

Please email me for my project to test.

Has anyone noticed this?

Hi Lucky Fish,

I apologize for the delay. Could you provide me with your project as you offered? I’ll be happy to look into the issue and if it is indeed a bug with the editor, I’ll enter it into our database. I’ll be attempting to reproduce it myself in the meantime based off your description.

Same problem for me, I just used the spline tutorial and changed the collision to “use complex as simple” and it stopped working since I loaded it into 4.8

Hi Roel,

I tried getting this issue to happen using a new project based on the first person shooter template and made a SplineMeshComponent, applied the Floor mesh to it (which has Use complex collision as simple by default) and placed a cube over top of it. In 4.7.6, the cube goes right through, but in 4.8 P2 (on a fresh 4.8 P2 project and one converted from 4.7.6) the cube collides with the SplineMeshComponent. Could you either send me screenshots of the settings of your SplineMeshComponent / the mesh itself? If possible, a test project where this occurring would be even better.

Oh nothing has changed in the last two previews either, so its still a bug on preview 3.

You can send it by attaching it here on answerhub using the paperclip symbol, or if it is too large, you can upload it to a third party hosting site such as Dropbox or Mega and post the link. I still haven’t been able to reproduce the issue myself, so I will need your project to see the issue itself.

I don’t want it to be public only for your testing

That’s alright. If you can upload the project to Dropbox and send me a private message on the forums, that would work. My username on the forums is:

I have sent you a PM!

I have sent you my project in a pm!

Thank you, I see the problem and I’m looking into exactly what is causing it. It could be the conversion itself but I’m making sure.

Hi Lucky Fish,

I’ve successfully identified the issue and it seems to be due to the use of ‘Use Complex Collision As Simple’ in 4.8. As ‘Use Complex Collision As Simple’ does not work with objects that are simulating physics, which is by design, it should work for static objects such as your tube. The issue seems to be that any static object using ‘Use Complex Collision As Simple’ ignores collision with any objects that are using ‘Simulate Physics’. For your reference the bug number is UE-15899. Unfortunately I have no workaround to offer at the moment other than suggesting that you could make your own custom collision for the tube.

Have a nice day,

Sorry for the late response, thanks for looking into it. Will this issue be solved before the final release of 4.8? Or do I have to go with the custom collision option?

Looking at the report, the issue has been marked as fixed as of this morning and it looks like it is planned to be fixed in the final version of 4.8. If it happens to be integrated in a preview version before the final release, I’ll be sure to update you here.

Cool, do i get karma points :slight_smile:

Karma points can be rewarded for having a popular question or by answering questions. If your question gets upvoted, which I upvoted it as I’ve started doing for reports of bugs that I put into the database, it does give you a small amount of karma.

Thanks for the info!

I also upvoted, enjoy the extra karma :stuck_out_tongue:

Thanks! It’s fixed! For me it works fine with 4.8 preview 4.