[4.8.1] - Material/Blueprint Graph + General Editor Funkiness

Hey Guys,

I’m noticing some issues but they are odd and hard for me to track down except for the first.

#1:

  • Try this out w/ a game level that has a strong emissive Lens Flare and what is happening is if the editor has 2 Slate Windows open (haven’t tried in Standalone w/ 2 Clients), Post Processing Elements on their buffer can end up on the other Window and not the one originating it.
  • To Repro: Two ways found so far…
  • Use a Dual-Monitor Setup and put the Material Editor Window for some Material full screen on 1 monitor and have the editor full screen on another. Crank up the Emissive on the Material and you will see a Lens Flare Generated in the Editor. Mind you this is with no Actor in the Level that uses this Material.
  • The second method is to have an Actor in the level that uses that Emissive Material and run 2 client Slate Windows. If you walk the character up to the object, instead of the Lens Flare appearing in their Window, it appears on the second client window, even when the Actor is not visible.

One thing I’d like to add to the above is just in general on Lens Flares in 4.8.1 is that they randomly will just flicker and makes it unbearable in VR if present. I mentioned the above on the forums but didn’t see a direct response so I wanted to add that to this post.

#2:
Material Editor - When having Comment Descriptions for individual graph nodes, they can sometimes all be collapsed randomly. I don’t have any steps to repro but noticing this happening over 20 times last night and me needing to keep clicking each one to see if it had one and open the comment bubble. This got extremely annoying when working on a complex material last night. Fun times :slight_smile:

#3:
Blueprint Editor - WorldContextObject is back and many nodes now have expanded this making them all slightly larger. I’ve seen this before and don’t know why it happens. Also other nodes sometimes (in the case when connected to an IsValid) just disconnect the Object Pin randomly on their own.

These aren’t major issues but the second and third especially are a major pain. Also, how come there is inconsistency between all graph editors in UE4. For instance, some graphs let you resort variables while others don’t. Resorting is another one that if allowed, is handled different. For instance in UMG, you can resort an item simply by dragging it to where you want it inserted, you are shown that line that shows the level it will appear at when dropped and works as expected similar to many UIs out there.

Taking the example of resorting. Some places in the engine (and maybe this is more inconsistency in editor UI as well) will be a mix of the following: Resorting is not allowed, resorting is allowed and is like described above, resorting is allowed but you need to use an Up or Down arrow, and finally resorting allowed and taking the variable (in BPs) and hovering it over the variable you want it to show on top of. That’s 5 options w/ 1 not allowing you to resort something at all.

Also, the difference between BP and StaticMesh editor is another example. In the BP editor, you can change camera speed, select if you are going to modify the transform, etc but in the SM Editor, you can’t.

These are some things I’m sure Epic has planned but I wanted to express that these changes will help make a better engine down the line as well as point out a couple bugs to fry :wink:

Hope the team is doing well and thanks!

Hi MC -

  1. I have tired both reproductions for this issue and have not been successful as of yet. If you could share the project and post process settings that you are using to reproduce this issue I feel I might have better luck. With just a blank project with no starter content I have not been successful in reproducing the lens flares. If you can get it in a blank project, feel free to upload or link to that blank project.
  2. The only way I could get this to “reproduce” is by not having the comment bubble scale while zooming and at a certain point the bubble will not be rendered as an object too small, but will come back if I zoom back in place. Again, here is that is not the case, can you post the material that you were using when this issue occured for you.
  3. This is a somewhat complicated issue and I am going to break this up a little. First I have entered a feature request for the uniform nature of the sub-editors in the engine, UE-18265. For the WorldContextObject, can you post that particular issue in a new Answerhub post? I want to make sure that gets some attention from our BP gurus.

Let me know about the 1 and 2 -

Thank You -

Eric Ketchum

Hey Eric,

Missed this answer, didn’t notice the email from AnswerHub.

Thanks for getting back to me on this one.

  1. This may be a NVidia related issue so lets see here. Okay, so what I did just now was split off the material window for a new material and I left aligned the editor to the left and the material editor on the right (not windows snapped, simple moved to both sides). So now I’ve got two separate slate windows. Hooking up an emissive on the right and jacking it up is causing blooming (as expected) but I can now see Lens Flare Reflections from the emissive glow showing in my viewport on the left side. It took some messing around but I had to de-snap the second just now and was able to capture a screenshot.

https://vgas4a.by3302.livefilestore.com/y3pzDvcbdn8EpNtsgcsNTwY8kYoHpUDhwLVcP7m8ub0p0zc3WJkNYBvi-6UIOOK-c3Lzy96LdBKI9ToclWzCJWas5LMuirU9RilNWMsmVPayO-KeSD4HtK-2x9FLdJkb-mvHc9tECfIaEAICRgdMwycxA/Lens%20Flare%20Bug.jpg?psid=1

Link: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

  1. For this one, I had this constantly yesterday. What it might have to do with to repro it is having it open as an additional tab. When working, I had it, and all the associate Material Functions in use open on their own tabs. When going between, I would constantly note collapsing of all comments. Also as a heads up just in case, this is not the comment blocks using ‘C’ but rather the Description for the node. It’s a confusing one but if I can help you nail it down, let me know.

  2. Sure absolutely. I’m sorry it was a whole lot all at once :slight_smile:
    [4.8.1] - Bug w/ BP Nodes Exposing 'World Context Object' - Blueprint - Unreal Engine Forums

EDIT: I noticed my screenshot link is dead so I just updated it, thanks! :slight_smile:

Hey MC -

Not having a lot of luck replicating your issues as of yet.

For the Lens Flare issue can you let me know what your Video Card and VIdeo Card Driver Version number is? Also check to see if you update your video driver if this issue resolves itself? I have been trying to replicate it and have not been able to yet on a few different machines here, but we all have very similar graphics cards, so I want to check your setup.

For the Comments disappearing, can you post a screenshot of the material you were working on that this occurs the most often. I want to try to replicate it and play around with perhaps something about what you are using is actually causing the odd behavior.

Thank You

Eric Ketchum

Hey Eric,

Thanks for reaching back! I see that my screenshot link is dead again :confused:

I’m guessing something has changed in OneDrive recently w/ using Original Picture links…

I’m going to do something even better and give you all the functions and materials :slight_smile:

Just sent a pm to your account. Let me know what you think.

It’s an EVGA 980 GTX SC 4GB GDDR5 - (Reference Design)

Driver: 353.30

OS: Windows 8.1 Pro

Thanks again!

EDIT: Updated screenshot above w/ Lens Flare issue. What I’ve noticed is the second I move back, the backbuffer used on the Editor viewport window refreshes and eliminates the reflections. But I noticed that it keeps accumulating until focus on that window has happened.

Hi MC -

So the comments disappearing I was able to reproduce. Specifically it only occurs for me when I save a Material Function connected into a Material, the Material will lose all of its comments. The good news here is that whatever was causing the issue does not seem to be broken in the internal main branch. So, a fix is forthcoming here.

The Lens flare issue I have still not been able to reproduce it. I am going ask around here to see if anyone might have encountered this issue before, but I would ask if you have updated your video drivers recently, try dropping down a driver version to see if that fixes the issue.

Thank You

Eric Ketchum

Hey Eric,

Thanks a bunch and glad you were able to track it down and a fix is coming. For the Lens Flare issue, of course either shoot another post here or PM me if you need me to test out anything for the engineers. I’m sure if I spent a good little bit on it, I could come up with definitive steps but like you mentioned, it could be specific to my video drivers. I’ll attempt to roll back before the initial GTAV driver release. I know right before those came out, things in general were running better so maybe there is a hope that the driver specifically is causing the glitching to show up.

Let me know if you need me to dig deeper and thanks buddy for the assistance once again. Much appreciated!

EDIT: And if I determine it is driver-related, I will notify you so you know for future reference Eric, take care