[4.7.0p8] [4.7.0] [4.7.1] Crash on startup from converted project

Hihi,

I got around to checking out preview 8 today, and the editor crashes on startup when I convert my 4.6.1 project. Preview 7 was fine for me; I’ve done some work on my project in between trying preview 7 and 8, just blueprints and UMG. I removed the UMG assets since I thought that might be the problem, but I got the same error.

Anyway, I’ll attach the log and the dmp (although I’m having to rename the dmp as txt to get it to upload - I hope that’s cool!), and hope this is fixable: I really want the new blueprint compiler/linker.

If you need anything else, just ask!

Edit: This is also present in the 4.7.0 release.
Edit2: And in 4.7.1 :slight_smile:

log

dmp as txt

Hello MkII,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this in a clean project?
  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?
  3. When you say " but I got the same error", could you provide the error that you are receiving?
  4. Could you provide screen shots of any blueprints that may be involved in this issue?

Hey Rudy,

I realise you’ve got nothing to go on to help me with this, so I started binary searching my project. Sure enough, there’s one BP that breaks. If I take this BP out, then I can load my project, and add it back in. If I reload my project with it in though, it breaks.

I started removing things from this BP bit by bit, but only when I removed both of the events in the BP and the one function on it as well could I open my project with the BP present. Here are some screenshots of the BP in question:

Begin Play:

Event Tick:

Shine Light Ray (part 1):

Shine Light Ray (part 2):

Apologies if the logic is hard to follow - I rearranged the nodes to get it all in a screenshot. I can provide the BP as well (not sure if it’s any use, but more information is better):

[Zipped BP][5]

I tried recreating this in a clean project by just dropping my BP into it, but the BP 2D sidescroller project with this BP added loaded just fine.

And finally, to answer your question 3, I meant that even after I removed the UMG assets, I still got a crash on load with the same callstack (i.e. the extra UMG work I had done between previews 7 and 8 was not to blame, and was irrelevant - not sure why I added that to the OP).

Let me know if you need more information - I’ll admit I can’t think why it’s this BP that is breaking. I am positive it was present when I tested my project in preview 7, and I don’t believe I have changed anything in it between the two.

Hello MkII,

First off thank you for all the information that you provided. However, after looking over your blueprint I was unable to determine what it is that may be causing your issue. Would it be possible to provide a copy of your project so that I can take a more in depth look? If you can provide your project and you would like to do so privately, you can send me a private message on the forums. Otherwise you can post a dropbox or something similar in your next reply.

Hey Rudy,

I PMed you a link on the forums; probably better than littering answerhub with what will eventually be dead links.

I haven’t yet tried making the BP from scratch in the 4.7 preview; I hope to get around to it this weekend. Hopefully that should prove to be a workaround, and it’s just that a port from 4.6.1 is corrupt, not a fundamental issue with the BP logic. I’ll report back with the results.

Let me know if you have any issues with the dropbox, or need further help!

I’ve got the same kind of problem today on 4.7 preview 8. My project is 4.7 from the start, but I’ve upgraded few days ago from previous preview. I couldn’t open it anymore. At the end, I deleted the defaultgame.ini, this allowed me to open it. However still wasn’t working and crashed when I tried to open the maps. At the end, I found that in some blueprints some links were broken. I had a function that took a reference to self parameter and the link disappeared. Once reconnected and recompiled, I was finally able to load the maps and the project works fine again. However, at each reopen of the project I have to fix that BP broken link issue.

It seems like some blueprint save issue.

Here my report: Unreal Engine 4.7 Preview 8 Unable to Open Project - Programming & Scripting - Unreal Engine Forums
I hope it helps.

I post this comment also here because my post was marked as resolved, not sure what exactly does it mean, but the bug is still here, whatever

Found how to avoid the problem.
This will crash at load:

and this will work properly:

So having tried to make this BP from scratch, the editor loads fine if I just make the BP and don’t correct the references that other BPs have to this BP. If I then fix up the references in the BP_TimeManager BP (which I think is the only BP referencing this BP_Sun BP), I get the crash on loading the editor again.

Unfortunately this means I don’t have a work around for this issue. The best I could do is try to recreate the BPs referencing this ‘broken’ BP from scratch as well, but I kind of doubt that would work. For now, I’m leaving this until the next Preview is out or 4.7 is rolled out; if it’s still present I can try to find a work around then.

Cheers!

Hello berguina,

This is another issue (UE-10285) that is known already and I do not believe that these two are necessarily connected. This issue comes from calling a self reference with begin play that is connected to a create widget node.

Make it a great day

I’ve found another one that crashes the editor. It’s related to self reference and not called from event begin play nor related to widgets.
I think it’s a problem of saving or loading blueprints, that’s why I still think it’s related.

With the release of 4.7.0, I can confirm this is still an issue. Trying to get this to work, it seems it is related to the function ShineLightRay, or more specifically, the input variable type BP_Node on this function.

I tried adding a BP_Node variable to the BP as a variable, and this also causes the crash, indicating that if there’s a reference to BP_Node in my BP_Sun blueprint, the crash happens. Could this be a cyclic dependency issue, that only manifests on load (compiling the blueprint with a reference to BP_Node in it is perfectly fine)?

Please let me know if you manage to repro this!

Hey Rudy,

I know you guys are busy, but have you had a chance to see if you can also get the repro on this? And would a fix for this be a candidate for a 4.7.1 release? I’m stuck on 4.6.1 at the moment because of this, but I’d love to get on 4.7 due to its blueprint and UMG fixes.

Cheers!

Good news!

I was playing around with my project in 4.7.1 and I realised that if I take out my BP_Sun blueprint, open the project in 4.7.1 and replace the blueprint, then reopen the project, it loads fine! So this’ll let me play with 4.7.1 with my project.

Cheers!