[4.6]Project crashes on load

I was working on my project last night, and everything was working fine, no problems at all. I did quite a lot of work yesterday, and tested the project by playing in editor several times. No errors reported. Now this morning, it wont let me load the project, it crashes as soon as it starts loading my project. Reading some other crash on load reports, I removed DefaultEngine.ini and was then able to access the project. But it did not load my Example_Map that I had been working in, I tried loading the map, and it crashed again. Reloaded, tried accessing MyCharacter, and it crashed again.

Here are my log/dmp files:
link text

I took a look through the previous log file from last night to see if there was anything that stood out as warnings of problems, Only thing I saw was this, just before it closed down.

[2014.12.07-06.20.22:105][690]LogActorComponent: UnregisterComponent: (/Engine/Transient.CharacterMovementComponent_6) Not registered. Aborting.

I moved the MyCharacter asset from my project backup to this one, and it is now working. Was able to load Example_Map, and play the game in editor.

I have noticed that 4.6 is handling casting to blueprints a little different, I have had to expose variables for me to access from other blueprints. My main use of this right now in this project is for my current test HUD to get variables from MyCharacter to display test info and ammo count.

The only other thought are blueprint interfaces. I have all my guns as seperate actors, and use a blueprint interface to send messages to them, such as ‘Shoot’. And it was working beautifully yesterday, even with multiple close/saves. But thats pretty much the only thing changed between this older MyCharacter and the new one.

Hello Interitus384,

It sounds like you’ve already fixed the issue on your end, but I’m following up. Are you still having trouble resulting from the conversion? I could investigate the crash further with your MyCharacter, but it sounds like your project is too interconnected for me to reproduce your crash that way.

There have been some changes to the way casting works, and we’re fully investigating reports of problems caused by those changes. If you see any more problems with casting, please report those too.

If you don’t have a way to reproduce the crash and don’t have any more problems with your project, I’ll mark this question as Resolved.

Regards,

Jonathan

Ive fixed it to the point that I got back into my project. But im not sure what caused that blueprint to be corrupted, and im hesitant to reimplement what I had done before. I can attempt to open the corrupted bp in a different project tonight and try to get an idea of what could have gone wrong.

Well, its crashed/corrupted my project again. If I remember correctly, I had been working on the project, saved and quit, reloaded the editor successfully. Then I went back in and added an interface for interacting with objects.
Sphere trace → hit object → send interface message to interact with object. That was the last thing I did.

link text

It seems to just be MyCharacter bp getting corrupted, reverting that to last stable version allows me back in my project.

Something with blueprint interfaces, or the way I’m using them. Everytime I implement them my MyCharacter blueprint gets corrupted.
My character spawns Actor GunWeapon and stores the reference in a variable of type GunWeapon. Then I want to make that gun active, so I store that reference in a variable “ActiveWeapon” of type Actor. When I go to shoot the gun, I reference ActiveWeapon and send it an interface message “shoot”.
For some reason, that is corrupting my blueprint. Am I doing something wrong or is there a bug?

That actually makes it sound like your blueprint interface is corrupt. Could you send us that asset - or a stripped-down version of your project? If we could reproduce the issue internally it would be much easier to fix.

Ok, these blueprints are from a version of the project that is corrupted. I can load the project, but I attempted to load the “gunPistol” blueprint and it crashed the editor. I tried opening several blueprints, and anything that used the interface or referenced MyCharacter was crashing. I used the FPS blueprint project as a base for the project.

[link text][1]

  • I opened an older version of the project, where the gunPistol and interface blueprints are in the content browser but not used, and the interface isn’t enabled on MyCharacter. I can load the interface and the gunPistol blueprints without crashing.
    [1]: 24181-blueprints.zip (160 KB)

I’ve had a similar problem with blueprint interfaces that used custom made classes as Input or Output.
I got around it by using Actor as an input instead, and I casted the actor to my specific class when I needed it.

Since the crash only happened at run-time (and every time I opened my custom made class beforehand it no longer crashed) my guess would be that the engine loads the interface before the custom made classes and since it doesn’t find them, it just crashes?

Do you have a set of steps we could follow to reproduce this crash internally? That would help us find the cause of the crash.