[4.6.1] Trying to set up ShooterGame new project to work outside of editor.

I am trying to set up my ShooterGame project so that I can launch it without the editor (DeugGame) or anything non-editor. But I am running into issues where the game window is just black.

Here’s all the lines from the debug output log minus the PDB spam:


FMallocCrash overhead is 3780608 bytes
First-chance exception at 0x000007FEFD5F940D in ShooterGame-Win64-DebugGame.exe: Microsoft C++ exception: xSharedMemoryException at memory location 0x000000000054EDB0.
LogInit:Display: No sandbox specified, assuming ../../../../UT/Epic Games/4.6/../../../Unreal Projects/Fortress/Saved/Cooked/WindowsNoEditor
LogInit: Version: 4.6.1-2386410+++depot+UE4-Releases+4.6
LogInit: API Version: 2369412
LogInit: Compiled (64-bit): Dec 11 2014 21:33:04
LogInit: Compiled with Visual C++: 18.00.21005.01
LogInit: Build Configuration: DebugGame
LogInit: Branch Name: ++depot+UE4-Releases+4.6
LogInit: Command line: 
LogInit: Base directory: E:/Unreal Projects/Fortress/Binaries/Win64/
LogInit: Rocket: 1
[2014.12.24-16.28.53:355]  0]LogTaskGraph: Started task graph with 3 named threads and 4 total threads.
[2014.12.24-16.28.53:377]  0]LogOnline:Display: STEAM: Loading Steam SDK 1.30
[2014.12.24-16.28.53:665]  0]LogOnline:Error: STEAM: Steam User is NOT subscribed, exiting.
[2014.12.24-16.28.53:667]  0]LogWindows: FPlatformMisc::RequestExit(0)
[2014.12.24-16.28.53:668]  0]LogOnline: STEAM: [AppId: 0] Client API initialized 0
[2014.12.24-16.28.53:670]  0]LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()
[2014.12.24-16.28.53:672]  0]LogOnline:Warning: STEAM: Steam API failed to initialize!
[2014.12.24-16.28.53:673]  0]LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()
[2014.12.24-16.28.53:673]  0]LogOnline:Warning: Unable to create OnlineSubsystem module Steam
[2014.12.24-16.28.53:674]  0]LogOnline:Warning: Unable to load default OnlineSubsystem module Steam, using NULL interface
[2014.12.24-16.28.53:686]  0]LogOnline:Verbose: NULL: Created thread (ID:12116).
[2014.12.24-16.28.53:687]  0]LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
[2014.12.24-16.28.53:743]  0]LogVoice:Warning: Failed to initialize voice interface
[2014.12.24-16.28.53:745]  0]LogInit: Presizing for 50000 objects not considered by GC, pre-allocating 1048576 bytes.
[2014.12.24-16.28.53:761]  0]LogInit: Object subsystem initialized
[2014.12.24-16.28.53:766]  0]LogConsoleResponse:Warning: Skipping Unknown console variable: 'UIScaleCurve = (EditorCurveData=(Keys=((Time=480.000000,Value=0.444000),(Time=720.000000,Value=1.000000),(Time=1080.000000,Value=1.000000),(Time=8640.000000,Value=8.000000))),ExternalCurve=None)'
[2014.12.24-16.28.53:767]  0]LogConsoleResponse:Warning:   Found in ini file 'E:/Unreal Projects/Fortress/Saved/Config/WindowsNoEditor/Engine.ini', in section '[/Script/Engine.RendererSettings]'
[2014.12.24-16.28.53:778]  0]LogInit: Selected Device Profile: [WindowsNoEditor]
[2014.12.24-16.28.53:780]  0]LogInit: Applying CVar settings loaded from the selected device profile: [WindowsNoEditor]
[2014.12.24-16.28.53:811]  0]LogInit: Computer: JD-PC
[2014.12.24-16.28.53:812]  0]LogInit: User: JD
[2014.12.24-16.28.53:812]  0]LogInit: CPU Page size=4096, Cores=2
[2014.12.24-16.28.53:813]  0]LogInit: High frequency timer resolution =2.083447 MHz
[2014.12.24-16.28.53:814]  0]LogMemory: Memory total: Physical=8.0GB (8GB approx) Virtual=8192.0GB
[2014.12.24-16.28.53:815]  0]LogMemory: Platform Memory Stats for WindowsNoEditor
[2014.12.24-16.28.53:815]  0]LogMemory: Process Physical Memory: 56.06 MB used, 56.06 MB peak
[2014.12.24-16.28.53:816]  0]LogMemory: Process Virtual Memory: 25.96 MB used, 26.03 MB peak
[2014.12.24-16.28.53:816]  0]LogMemory: Physical Memory: 3535.86 MB used, 8190.30 MB total
[2014.12.24-16.28.53:817]  0]LogMemory: Virtual Memory: 256.55 MB used, 8388608.00 MB total
[2014.12.24-16.28.54:115]  0]LogD3D11RHI: Found D3D11 adapter 0: NVIDIA GeForce GTX 460 v2 (Feature Level 11_0)
[2014.12.24-16.28.54:116]  0]LogD3D11RHI: Adapter has 977MB of dedicated video memory, 0MB of dedicated system memory, and 3071MB of shared system memory, 1 output[s]
[2014.12.24-16.28.54:117]  0]LogD3D11RHI: Chosen D3D11 Adapter Id = 0
[2014.12.24-16.28.54:143]  0]LogRHI: Texture pool is 684 MB (70% of 977 MB)
[2014.12.24-16.28.54:234]  0]LogD3D11RHI: Async texture creation enabled
[2014.12.24-16.28.54:400]  0]LogTextLocalizationManager: The requested culture ('en_US') has no localization data; falling back to 'en' for localization and internationalization data.
[2014.12.24-16.28.54:403]  0]LogContentStreaming: Texture pool size is 1000.000000MB
[2014.12.24-16.29.00:880]  0]LogWindowsMoviePlayer: Unable to load movie: ../../../../UT/Epic Games/4.6/../../../Unreal Projects/Fortress/Content/Movies/LoadingScreen.mp4
[2014.12.24-16.29.00:973]  0]LogAssetRegistry: FAssetRegistry took 0.0600 seconds to start up
[2014.12.24-16.29.01:455]  0]LogSlate:Warning: Failed to load font data from '../../../../UT/Epic Games/4.6/../../../Unreal Projects/Fortress/Content/Slate/Fonts/Roboto-Black.ttf'
[2014.12.24-16.29.01:471]  0]LogSlate:Warning: Failed to load font data from '../../../../UT/Epic Games/4.6/../../../Unreal Projects/Fortress/Content/Slate/Fonts/Roboto-Medium.ttf'
[2014.12.24-16.29.01:474]  0]LogSlate:Warning: Failed to load font data from '../../../../UT/Epic Games/4.6/../../../Unreal Projects/Fortress/Content/Slate/Fonts/Roboto-Regular.ttf'
[2014.12.24-16.29.01:476]  0]LogStreaming:Warning: Failed to read file '../../../../UT/Epic Games/4.6/../../../Unreal Projects/Fortress/Content/Slate//Images/SoundCue_SpeakerIcon.png' error.
[2014.12.24-16.29.01:477]  0]LogSlate: Could not find file for Slate resource: ../../../../UT/Epic Games/4.6/../../../Unreal Projects/Fortress/Content/Slate//Images/SoundCue_SpeakerIcon.png
[2014.12.24-16.29.01:527]  0]LogObj: 24440 objects as part of root set at end of initial load.
[2014.12.24-16.29.01:528]  0]LogObj: 895 objects are not in the root set, but can never be destroyed because they are in the DisregardForGC set.
[2014.12.24-16.29.01:529]  0]LogUObjectAllocator:Warning: 5822224 Exceeds size of permanent object pool 1048576, please tune SizeOfPermanentObjectPool.
[2014.12.24-16.29.01:530]  0]LogExit: Preparing to exit.
[2014.12.24-16.29.02:011]  0]LogExit: Object subsystem successfully closed.


I assume it has something to do with the fact that it cannot find the movies or fonts+images? Which I cannot find, yet the HUD fonts seem to work while in PIE. I don’t know why its trying to traverse directories like it is either.

The fonts do exist within the sample content, but I had to manually copy those (and it still cannot see them). However I cannot find the movie to load or the speaker icons.

Hi, i’m in the same situation with the latest 4.7.2 engine : everything works inside the editor, as soon as it’s outside, it freezes at the UE4 logo.

Looks like it’s crashing because it can’t find the fonts, though I’m sure those fonts are included at Engine-level, not ShooterGame level.

As a test, could you create a new ShooterGame project and NOT rename it, then try to compile and run? I know already that 4.6.1 ShooterGame compiles and runs, but i never tried re-naming the project. I wonder if it’s something to do with the renaming not working properly.

Hi TheJamsh, it seems i do not have the same problem like Ensiform. This is my log : (i did not rename the project)



LogPlayLevel: ShooterGame: Error: {ERR-001} [Session] REJECTED: OVRService did not authorize us: Incompatible protocol version.  Please make sure your OVRService and SDK are both up to date.
LogPlayLevel: ShooterGame: LogOnline:Display: STEAM: Loading Steam SDK 1.30
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.06:963]  0]LogOnline:Display: STEAM: Loading Steam SDK 1.30LogOnline:Error: STEAM: Steam User is NOT subscribed, exiting.
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.08:133]  0]LogOnline:Error: STEAM: Steam User is NOT subscribed, exiting.LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.08:265]  0]LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()LogOnline:Warning: STEAM: Steam API failed to initialize!
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.08:295]  0]LogOnline:Warning: STEAM: Steam API failed to initialize!LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.08:295]  0]LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()LogOnline:Warning: Unable to create OnlineSubsystem module Steam
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.08:427]  0]LogOnline:Warning: Unable to create OnlineSubsystem module SteamLogOnline:Warning: Unable to load default OnlineSubsystem module Steam, using NULL interface
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.08:428]  0]LogOnline:Warning: Unable to load default OnlineSubsystem module Steam, using NULL interfaceLogVoice:Warning: Failed to initialize voice interface
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.08:975]  0]LogVoice:Warning: Failed to initialize voice interfaceLogConsoleResponse:Warning: Skipping Unknown console variable: 'UIScaleCurve = (EditorCurveData=(Keys=((Time=480.000000,Value=0.444000),(Time=720.000000,Value=1.000000),(Time=1080.000000,Value=1.000000),(Time=8640.000000,Value=8.000000))),ExternalCurve=None)'
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.10:248]  0]LogConsoleResponse:Warning: Skipping Unknown console variable: 'UIScaleCurve = (EditorCurveData=(Keys=((Time=480.000000,Value=0.444000),(Time=720.000000,Value=1.000000),(Time=1080.000000,Value=1.000000),(Time=8640.000000,Value=8.000000))),ExternalCurve=None)'LogConsoleResponse:Warning:   Found in ini file '../../../ShooterGame/Saved/Config/WindowsNoEditor/Engine.ini', in section '[/Script/Engine.RendererSettings]'
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.10:248]  0]LogConsoleResponse:Warning:   Found in ini file '../../../ShooterGame/Saved/Config/WindowsNoEditor/Engine.ini', in section '[/Script/Engine.RendererSettings]'LogStreaming:Warning: Failed to read file '../../../ShooterGame/Content/Slate//Images/SoundCue_SpeakerIcon.png' error.
LogPlayLevel: ShooterGame:
LogPlayLevel: ShooterGame: [2015.03.05-17.35.24:935]  0]LogStreaming:Warning: Failed to read file '../../../ShooterGame/Content/Slate//Images/SoundCue_SpeakerIcon.png' error.LogUObjectAllocator:Warning: 5856000 Exceeds size of permanent object pool 1048576, please tune SizeOfPermanentObjectPool.