Download

[4.6.0] FPS drop / GPU and render time increase when looking away from models

The title explains it all, but I have a video demonstrating the problem. (I’ve tested it from multiple directions to make sure that it isn’t the level itself causing the problems) https://www.youtube.com/watch?v=bmpdSTDA14o

Does anyone have any idea as to what’s happening? I would’ve thought looking at an object would be more of a difference.

This is on UE4 4.6.0.

Thanks!

I have encountered the same issue, although my test project is a bit more extreme: 10000 Cube Render Test UE4 [4.7.1] on Vimeo

This was done using 4.7.1 and recorded using a full release build of the project. I have also attempted turning off post-processing to see if that would make a difference, as well as halving the amount of cubes, but it still gives me the same performance drop.

Note: The “10000” text is just an indicator for the amount of cubes currently spawned, as the project spawns one cube per one tenth of a second until it gets to 10000

Is anybody else seeing this? It’s rather severe - it’d be nice to at least know the cause.

I had this same problem. I turned off inset shadows on the objects and turning away from objects does not cause a slow down anymore.

I disabled the inset shadows (which are supposed to be forced off anyway? https://docs.unrealengine.com/latest/INT/Resources/ContentExamples/DynamicSceneShadows/index.html), and it seemed to help with the performance drop.

However there is still a drop in performance, which I find to be strange. From my own little projects and my understanding of 3D scene management, I would think performance would in fact increase due to the actors (or cubes in the example projects seen in HateDreads post and mine) not having to render, only update…

I’m just curious to find out if this is a fault with the engine or just an oversight that I can’t figure out