[4.6.0 AI Navigation] [Repro Project] Character will not use Navigation mesh if their collision capsule is greater than 172 height, Repro Project For You

Dear Friends at Epic (And Mieszko!),

I am having a severe problem!

If I make character’s capsule bigger than 172, in 4.6.0, the character will not use my navigation mesh!

#Tried All the Settings I could find

I’ve tried fiddling with every possible value I can find

I thought the most likely would be not having Project to Navmesh set to true (MoveToLocation), but setting it to true did not help.

ProjectSettings->NavigationMesh, Agent Height, max height
ProjectSettings->Navigation System, ignore height when picking nav data

CharacterMovement->Agent Height and Radius, making these bigger does not help

Update Nav with owner collision-> makes no difference

#Repro

1.Make a new blueprint third person project with no starter content

2.Add this graph to the MyCharacter BP

3.Spawn the MyCharacter BP with a default controller via level BP, on key press

4.Notice it works

5.Now resize the collision capsule to be 174x174, or anything higher than 172x172

6.Resize character to match new capsule if you like

now run the game again and spawn some units, and notice they dont move!

#Repro Project

If you have any trouble reproducing this I will give you a repro project :slight_smile:

I’ve reproduced this issue in the following projects

1. My main project where issue was first discovered
2. C++ third person template
3. BP third person template

#Repro Project (23.3 MB download)

I am providing you with a repro project that illustrates my issue!

  1. Download the repro project here Cahoots — Ann Arbor tech coworking
  2. select the .uproject and right click, switch engine version to 4.6
  3. Go in editor, and go in game in PIE
  4. Press the T key, notice how spawned creatures are not moving
  5. Go to MyCharacter BP, and reduces the capsule height to 70 from 174
  6. Now the units will start moving!
  7. Change the capsule height back to 174 and notice they no longer move!

#My Issue

I cannot figure out how to get the units to move when their radius is 174! No matter what nav mesh and NavAgentProps settings I play with, they still do not move!

#Help!
I cannot proceed with AI until this matter is addressed!

#:heart:

Rama

Hi Rama,

Unfortunately I was unable to reproduce this on my end, I scale the capsule height and radius to 180x180 and did not see any errors when attempting to move the player character. Do you have any other steps that I can take to reproduce this on my end?

I am a little confused, the player character?

I am talking about AI, not player controlled units :slight_smile:

#Repro Project (23.3 MB download)

I am providing you with a repro project that illustrates my issue!

  1. Download the repro project here Cahoots — Ann Arbor tech coworking
  2. select the .uproject and right click, switch engine version to 4.6
  3. Go in editor, and go in game in PIE
  4. Press the T key, notice how spawned creatures are not moving
  5. Go to MyCharacter BP, and reduces the capsule height to 70 from 174
  6. Now the units will start moving!
  7. Change the capsule height back to 174 and notice they no longer move!

#My Issue

I cannot figure out how to get the units to move when their height is 174! No matter what nav mesh and NavAgentProps settings I play with, they still do not move!

#Please Help!

Rama

Hi Rama,

I tested your project and your units seem to be moving as specified. I made a video to show you what I am seeing, is there anything I’m missing? You can find the video here:

#Thanks for Video Adam!

What version did you film that video on?!

For me, for both 4.6.0 release and 4.6.0 github build, this does not occur, the units just stand there.

I see you have the right height, because the feet are on the ground, so you are using 174 as I requested, thanks!

But for me, they just stand still and dont move, I’d like to get ahold of whatever version of UE4 you are using :wink:

Rama

#Upgrading to 4.6.1 Solved the issue

Dear Adam,

thanks again for your video!

After upgrading to 4.6.1, the issue was resolved :slight_smile:

If you Convert your comment to an answer I can give you proper credit for helping me out!

#:heart:

Rama