[4.5 Preview] Not cooking changes on iOS, not embedding provisioning profile

I have attempted to upgrade to 4.5 preview to test if there is any improvements on the “Read Leaderboard Integer” node for iOS.

However when I try and Test Level, it doesn’t seem to cook correctly, and any changes I make in the editor don’t make it onto the iPad, what I end up with is something that looks like I had hours ago (Deleted actors from level are still on iPad along with deleted materials which have been manually replaced.)

Secondly, when I tried a full rebuild with distribution checked, It doesn’t embed the provisioning profile, so I cannot upload to Apple Testflight.

I had no issues with either in 4.4.3.

Could you post a log from the editor for both issues? That would help me diagnose what the problem might be and if we need a fix before 4.5 is release.


Test Level Issue:
I was able to reproduce, by opening level on iPAD straight after converting it from 4.4.3 project. Then after building, delete the the game from the iPad, add a cube into the scene then retest the level, the cube it not there.
See log “TestLeveloniPad.txt” testlevellog

Shipping Distribution packaging Issue:
I converted project from 4.4.3, which had no prior issues with packaging for shipping/distribution. But in 4.5 preview, I receive “Invalid IPA: missing embedded provisioning profile” error while uploading to Apple TestFlight.
See log “PackageasShippingandDistrubution.txt” packaginglog! screenshot!

On a side note, the Dialogue box that pops up in the bottom right hand corner for various things seems to be broken as well (only tested on my Macbook Pro Retina). I cannot click on the buttons located within this box. I have also attached a screenshot of this. screenshot

So let’s start with the Distribution issue. Based on the log, it did sign it with your distribution provision and certificate and replaced the one inside of IPA. The IPA itself is just a zip file, so you can use the Archive application on the Mac to extract it to a directory and inspect. Can you do that and see if there is an embedded.mobileprovision file? If so, open that file with TextEdit. You can read portions of the file to determine what provision is being used. If that matches your distribution provision, then I think you may just need to recreate your distribution provision. There were some changes to the provision format with the iOS8 update and if you have an older provision then it might not work with the updates.

The cube not showing up I’ll have to talk with our rendering guys. I suspect it may be that new objects by default have lit materials and so its not rendering properly, but I’m not sure about that one as we haven’t seen it locally yet. I’ll have our QA try to reproduce as well.


Actually, just after I posted the last suggestion, I noticed the log showed that portions of the build are still using the 4.4 directories for various things. This might actually explain both problems. I’ll have QA perform a test, but in the meantime, try having the editor re-generate your Xcode project using File/Refresh Xcode Project. That should fix up all of the paths and might just fix both problems.


Howdy JBarnett,

Just wanted to reach out to you and still if the previous comments have helped you to fix your issue. please be sure to let me know whether it did or did not.

Thanks and have a great day!

The test level issue seems to have been resolved in the final version of 4.5. It wasn’t a rendering issue, because I could delete an object too and it wouldn’t show up. Was probably something cooking incorrectly.

As for the profile, I still have issues in the final 4.5 version. I have attached a copy of what is located within the IPA. I cannot see the “embedded.mobileprovision”. As for refreshing the Xcode project, how do I go about doing that. I am creating a blueprint only project. I did open the xcode project within the project directory, but I can’t find anything about refreshing it…

Also still having issues with bottom right hand corner popups with the editor…

In the UE4 Editor menu, under the File menu, there is an option to Refresh the Xcode project. If that is missing, then you have no code, but I thought you had mentioned you had added code to the project?

Also can you post the log from the editor which generated that IPA from above?


Sorry for the delay in my response, have been rather busy. I have no code presently within the project, only blueprints but this might change before I release the game.

I have attached the log link text

Ok, so looking at that log everything succeeded. For that to happen, there has to be an embedded.mobileprovision in the ipa otherwise Xcode would fail. Are you certain that you are looking at the ipa in /Users/joel/Desktop/TEST 4.5/IOS/Distro_SplitShot-IOS-Shipping.ipa? That is where the final IPA is being placed according to the log. I am still concerned that it looks as though you are using the UE4Game.app from the 4.4 directory instead of the 4.5 directory, but that shouldn’t be causing no embedded provision.


I am absolutely certain there is no “embedded.mobileprovision” in the .ipa file. I went back to the 4.4.3 project and packaged the game with the same settings and the embedded.mobileprovision is there. I have attached screenshot of the 4.4.3 project IPA file compared to the 4.5 project IPA file.

Ok so looking at that, the one with the missing provision also was never signed at all. Notice the missing CodeSignature directory. None of us have been able to reproduce this at all, so I really have no idea what the problem might be. Have you tried making a new project to see if that works? Also does it fail when you make a non-distribution ipa?

  • Pete

Ok, going through the log again, I think I know why you don’t have any embedded provision. It looks like it is signing the executable in your 4.4 installation of the engine. So a couple of possible things to look for/try:

  1. in the 4.5 project directory (/Users/joel/Documents/Unreal Projects/Splitshot 4.5) is there a file called SplitShot_IOS.xcodeproj? If so, delete it and try another package. It will get regenerated on the next package.

  2. Try re-naming the 4.4 engine installation to see if that gives us an error. So rename /Users/Shared/UnrealEngine/4.4 to /Users/Shared/UnrealEngine/4.4a That would potentially tell me that it is signing the wrong executable/payload and give us a place to start narrowing down.

I honestly think it is probably the first possibility which is causing the issue. If you ever had a successful Launch On, that XCode project will stay around and we never regenerate it if we find one already there (which is changing in 4.6 as we bring more potential settings in to the editor).


It looks like after I deleted the SplitShot_IOS.xcodeproj it seemed to embed the Provision. Fantastic!

I did notice that the Xcodeproject did not regenerate though…

Ya, it is automatically deleted during packaging. Technically it is a temp file, but when we do launch on there is a bug where the xcodeproject is not deleted after it completes.

Glad we got this sorted and I actually just fixed this yesterday by always regenerating the file even if we find it, so it shouldn’t happen in future releases.


Hi JBarnett,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.