[4.3] i can't load my project anymore


I am sorry to report my experience with 4.3 (preview and release) was not very good.

Everything went fine with 4.2.1, then i installed 4.3 preview and it was slow and very laggy.

4.3 release arrived, i tried to build the lights for the first time and the editor crashed.

I retried but it never went up from 0%

After a while i stopped the engine, which seems to go ok, but there was still a process in the task manager, which i killed, and then restarted my computer.

Now, when i try to load my project i get this:

I tried to uninstall and reinstall 4.3 but it didn’t change.

Anything i can to to recover my project ?

When trying to join the log file, i got the following message “the attachment is not permitted because the file type is invalid”. So i renamed it with the .txt extension and i could upload it. Here it is enclosed, but you’ll have to rename it with .log.



update: i could recover from an old “auto save” backup, from 3 hours before the problem. So the original map got corrupted somehow.

That’s frightening.

Well at least i got my map back and only lost 3 hours.

But if anyone reads this post and know how to read the logs, i would be nice to know what i did wrong to corrupt the map, so i don’t do it again.



mmm, unfortunately it’s not solved.

I tried to build the lights and it got corrupted again (this time i did nothing else but close and reopen).

So it seems that every time i try to build lights, my map gets corrupted.

I close that old one.

Answer will not come for 4.3 and would be meaningless anyway.