Download

4.26 How does "Generate Cards" Work?

Hey guys,

I wanted to test out the new “generate cards” function that was added in 4.26, but I can’t seem to make it do… anything.

I imported my groom from xgen, and everything seems to work fine. Shows up in viewport ok, everything seems to be working. I gave it a material, added 2 LOD slots. Then I went to the cards tab, and tried to generate cards. No matter what I do, nothing seems to happen. I set my source type to procedural, and hit the refresh button. Nothing. I tried both generation types, I’ve tried different settings, nothing seem sto ever happen. The only thing I get from the output log is:
LogHairStrands: [Groom/DDC] Cards - Not found (Groom:hair01_ABC Group:0).
LogHairStrands: [Groom/DDC] Meshes - Not found (Groom:hair01_ABC Group:0).

No idea what that’s referring to. I mean, I’m trying to make the cards. They don’t already exist.
I’m sure I’m doing something stupid, but I can’t find any other info on this function.

1 Like

Never mind, I have solved it, and the solution was appropriately stupid.

In order to generate cards, you must have set the geometry type for all of your LODs to be “cards” under the LOD tab, before attempting to generate the cards.
Then, for each cards group, make sure your Group Index and LOD index are the same, and match the LOD you want to use the cards for.

1 Like

I got the card generation to work without adjusting the settings at all, but the textures it created were all blank. Any idea how to fix that?