Download

4.22.1 When using Grass through the landscape material, there is one point where some of them float

As you can see, there is one point in my landscape where the grass floats. It only happens if I put it throught the material. If I paint directly it doesn’t happen.

A.JPG

I tried modifiying the terrain but it doesn’t change anything. The grass still floats.

I used to have this kind of problem constantly in an older version of UE4. You could try selecting the landscape and running the console command RecreateLandscapeCollision. If I remember correctly, that didn’t work for this particular issue, though. I think I ended up replacing the landscape completely by exporting a heightmap of the landscape and importing it onto a new one.

In the 4.22.1 that I am using now that command doesn’t exist.

Is there any way to recreate it? Maybe deleting some file?

I just tested it in 4.22.1 and the command still exists. However, as mentioned before, I’m not surprised that it doesn’t fix the foliage issue.

Recreating the landscape and importing the previous heightmap is the best advice I got, unfortunately. (In landscape sculpt mode, right-click the “Heightmap” layer to export and import.)

This are the results on my console
AAAA.JPG


I tried reimporting the height map and didn’t solve anything :-/

The command may not show up in the “search results”, but entering it will still work. When I use it on my landscape, there’s a “Building Grass Maps” progress pop-up.

As for reimporting the height map, did you also try it on a completely new landscape, maybe even in a new scene? If that’s still causing problems, that would be quite mysterious indeed.