4.21 and Dev-VR - New SteamVR Input breaks input in older versions of UE

I’ve been messing around with 4.21 and the Dev-VR branches for the new SteamVR Input with the Knuckles EV3 controllers. So far it’s worked pretty well.
However when I switch back to a project on earlier versions of UE things get a bit broken.
Once a SteamVR Input bindings .json file has been created for a project it gets associated with “ue4editor.exe” in “ProgramFiles(x86)/Steam/Config/steamvr.vrsettings”. As soon as you open any older versions of ue4editor.exe, it tries to use the input bindings you defined in the newer project. Which naturally doesn’t work, and stops ue4editor.exe from getting any input from the vr controllers at all.

I was able to temporarily fix the issue by going into “ProgramFiles(x86)/Steam/Config/steamvr.vrsettings” and deleting a section labelled “system.generated.ue4editor.exe”. Basically I have to keep a version of steamvr.vrsettings for older versions of ue4, and one for the newer ones.

I don’t know enough about UE4 and C++ to be able to try and fix it myself, but ideally it’d work more like Unity where it binds the input bindings to “application.generated.unity.[PROJECTNAME].exe” instead of straight to the editor exe itself.

Yes this is happening to me as well. Because of ue4editor.exe being seen as a single software, steam is confusing one project for another, and affects older UE4 versions too. Iv broken my vive input in every project I have except the tmp one i was mucking about with steam input in.

Update: Found a workaround to restore working order. I tried the tmp fix from above but it didn’t work for me, however there will be a steamvr folder in your documents folder. Just delete it, and restart steamvr. Inputs should work again.

Does this by chance also affect the AB and XY buttons on the Touch controllers? I’m on 4.21 and the Touch controls that used to work on SteamVR seem to have broken the buttons. The joystick and grip buttons still work, but anything tied to the buttons no longer work in SteamVR (they work in UE4 before compiling).

I’m trying to prep an update release and have been forced to update to 4.21 since the 4.19 and 4.20 branches seem to have been broken in SteamVR (stuttering and tearing). 4.21 fixes this problem but the Touch buttons are no longer working, so I’m kinda stuck. I’ve been digging through the forums looking for anyone who’s run into similar situations and this is the closest I can find, it seems. Unfortunately, neither of the above hack fixes seem to work for me.