Download

4.19 Datasmith not working

Hello everyone, i have been trying to get datasmith working in 4.19 because all of the future versions make my spotlights from corona turn into rectangle lights which makes no sense and does not work properly and 4.19 does not have this issue. I have tried downloading the exporter from this page https://www.unrealengine.com/en-US/studio/downloads but it only gives me the 4.18 exporter and not the 4.19 one when i choose version 4.19 in the drop down. I have tried all the other versions and they work properly but i noticed in system/Apps it only states the exporter downloaded from 4.19 is actually 4.18 only.

Does anyone have a legacy download of the 3ds max exporter for 4.19 or is there anywhere else to download this version besides that page…or maybe Epic can go in and fix it? Thanks.

Going through the same problem

I am having the same issue…wish Epic would fix this.

Hi all.

The version of 3dsMax Datasmith plugin for UE 4.19 downloadable from the site is version _4_19_18_3. I am fairly certain that is the correct file to align with the UE 4.19 release. The 18_3 element of the version number is unrelated to the Engine version, and was before we streamlined our versioning in later development.

Please bear in mind that it is well over a year old at this point, and Datasmith in the 4.19 release was very early in development experienced many issues. I would encourage you to stick to more recent versions, and please provide any feedback regarding struggles you are facing so we can ensure that the latest development is valuable to all.

Your fairly certain? Well it does not seem to be the correct file to align with 4.19, i cant be doing anything wrong as i used the same steps for all the other versions and they all work fine, so i would encourage you check this yourself.

I cant stick with the current versions because of the issue i stated above. It is converting all the lights in my corona scenes that are spot lights and point lights to rectangle lights in UE4 which is making Datasmith unusable for me currently, but i need it working in order to properly do my intended work…so the only solution is using 4.19 which does not have rectangle lights so it should convert the lights properly as it has before…but its not working.

So i need this solved or i need 4.23 to properly convert things ASAP which is not going to happen soon or might not happen until the next version which i cant wait for…so if you could please check yourself and confirm whether it is working or not and please have this fixed.

weird. this should not happen.

I’ve checked with our QA department and confirmed that version _4_19_18_3 (displayed as 0.18.3 in the installer) is the latest and correct installer for 3dsMax in alignment with UE 4.19.

For any Datasmith issues, please submit a report to: https://unrealstudiohelp.epicgames.com/s/case-community-page?language=en_US, however please bear in mind that we are no longer actively developing for early engine versions like 4.19.

Thanks

Not entirely sure this is relevant but its about Datasmith.
Wanted to use this feature, for GLTF which it supports but even though I have Datasmith plugin enabled ( & yes restarted), its not showing up on UE4 toolbar at top nor will import allow GLTF, given I have only access atm to Blender.

What gives or is this a known 4.24 issue ?

Make sure you also have the GTLF plugin enabled as it is disabled by default and required for it to work with datasmith :wink:

I just enabled GLTF, restarted, but datasmith still isn’t on top menu.
I know it was in beta for a while, must it now be purchased( studio which I never used so I know little about it ) in other to have access to use of datasmith ?

Datasmith is a free feature of the engine now !

Make sure you have enabled the “Datasmith Importer” and “Datasmith glTF Importer” plugins (you can also enable the Datasmith Content plugin).
After a restart of the engine, the Datasmith button should appear on your toolbar.

Hi Antoine and ty for reply :
" Make sure you have enabled the “Datasmith Importer” and “Datasmith glTF Importer” ", the later there is enabled( thoough it only says GITF Importer) but the former in your sentence I can’t find anywhere in plugin list

Should be the last one in the plugin list when filtering with the “Datasmith” keyword, under “Datasmith IFC Importer” . You are using Unreal Engine 4.24 right ? Up to date too ?

OK ,thx for responses, sorry to say my fault here, as though I had 4.24 set as current it loaded 4.23 anyway instead of prompting an error which I think is weird BUT regardless ofc, I started engine version and made copy of project as safeguard as is usual and all good, all in place! Sorry for confusion o-), I had tried to do that yesterday , was out of ssd space and forgot to do it again LOL. Look fwd to datasmith features!

TY