4.18 release source compile failed

4.18 release source compile failed, eror:

'Engine\Source\Programs\Mac\ShaderCacheTool\Private\ShaderCacheTool.cpp(66): error C2039: 'MergeShaderCacheFiles': is not a member of 'FShaderCache'

This error also exists in 4.18 preview, please fix it.

The same problem:

https://forums.unrealengine.com/development-discussion/engine-source-github/1368701-unable-to-compile-fresh-branch-4-18-clone

https://forums.unrealengine.com/development-discussion/engine-source-github/1368098-slim-down-engine-source-build

@Stephen Ellis

Plus one on this issue.

Heya,

I was getting the same error when I tried to build UE 4.18 release on Windows 10 Home x64 with Visual Studio 2017 v15.4.1
I tried to clean the solution and build again. . .but it failed.

Then I restarted Visual Studio as Administrator user privileges and did a rebuild.
It works !

Hope this helps.

I have tried your approach, it doesn’t work.

I know the reason:
In the header file “Runtime\ShaderCore\Public\ShaderCache.h”, the “FShaderCache::MergeShaderCacheFiles” method was removed,but it was called in “Source\Programs\Mac\ShaderCacheTool\Private\ShaderCacheTool.cpp”.

Epic should fix it.

the same problem

hello everybody,
same problem here… anything yet?

Remove ShaderCacheTool project from your solution

This has been fixed with Unreal Engine 4.18.2. ShaderCacheTool has been removed from Visual Studio solution in release 4.18.2

Now the Engine builds without any errors.

Yes, I have noticed this update.