Download

4.15 Indirect lighting samples not working?

So I’ve converted my scene from 4.14.3 and everything works well, except for a dynamic object not receiving the same ambient light.
Does anyone have any ideas?
64992a13fd0f70adf03d2df4d6beb1958ee158f3.jpeg

Did you rebuild your lighting?

Yes, rebuilt lighting to no avail. I also tried switching from ILCQ Points, to Volume, and it does give me another result, but still very blue-ish, which it shouldn’t be as there are no blue-ish indirect light points around.

No one? :frowning:

If you’re using an ambient cubemap and subsurface profile you need to do r.SSS.Checkerboard 1. If you’re not I have no idea.

Have you used Show->Visualize->Volume Lighting Samples to see if there’s any difference in the lighting cache between the two versions?

Is it just that one object in that location?

Thanks for the help, but I couldn’t see any difference.

I checked and there are actually more light samples in the new engine, despite the lightmass volume not stretching that far.

34a58af142b8a42b4bfcecc0901b76bb7afe597e.jpeg

It is the only movable object I have in the scene, but I added another sphere and moved around and it responded the same. It’s as if they are taking from a light sample farther away?

What do the samples look like inside the room?

You can try adding a lightmass character indirect detail volume to add more samples to see if it fixes the issue.

They look the same for both scenes inside, sorry, should have specified. I only found differences outside. Baking light to try indirect detail volume now, didn’t know about that one. Is that very expensive to use? My character blueprint also has a movable object, so maybe it’d be nice to have it for the entire room.

I can’t imagine they are expensive with the default settings, from what I’ve noticed you’d want one anywhere a character could go, and they are literally just a baked point in space that gets sampled. You might not want to fill an entire open landscape with one, but they can really help interiors.

Sounds like just what I need, however nothing appeared within the volume after baking. It’s as if it doesn’t care about my lightmass volumes at all. Is there a checkbox I’ve missed?

There was a change to volume sample placement in 4.15 which appears to be what is causing this. Previously, we would never place volume lighting samples outside of a lightmass importance volume, but this meant that some areas of the volume were not covered by samples (black indirect lighting). To fix this, we now allow samples outside the volume which are affecting positions inside.

However, the denser points placed on surfaces are supposed to override these sparse points to prevent leaking. I think you just need a denser setup of points inside. You should be able to achieve that with ‘Volume Light Sample Placement Scale’ in WorldSettings->Lightmass.

I increased the amount and it actually got brighter. I have no idea what’s going on - picture of mesh, samples and settings attached. The ball is part of a blueprint by the way.

Lightcomp3.jpg

I’ve many troubles with indirect lighting too, since 4.15 most of my interior volume are broken (brighter object) does this change was really necessary at all?

Anyone? Any ideas?

Sorry for bumping this again, but I really don’t understand the behaviour. Any devs who know how to solve this?

Same problem here

Again. Does anyone know why I get these results?