Download

4.14 FBX Animation Import Bug - Crash

There seems to be a bug in 4.14 when importing an FBX with an animation.

The same FBX file imports just fine in 4.13.2

I’ve attached the FBX here, which is a dead simple cube with rotation keyframes baked across 200 frames.

I have tried exporting from Cinema 4D and from 3ds max and with FBX version 7.4 and 6.1. UE 4.14 crashes every single time on import.

If I import the same file as a static mesh, it will import fine, without the animation.

Try applying a material to the object in your 3d software before exporting. It is probably this bug:

https://answers.unrealengine.com/questions/531805/fbx-importer-crash-on-skeletal-mesh.html

Just had the same issue. Every time i try to import a cat rig it will crash. Are you exporting from 3D s max?
if so what version are you using?

I’m using an older version *2014, and i’m thinking maybe its an old FBX export issue.

Today I did some tests between versions of studio max 2014 / 2016.

I first found that an import from both crashed UE4.
I then selected all geometry and applied a standard material (explained by lamwin). Did the same export and import and it worked, no UE4 crash.

Extra Note, related to root motion:
I found an issue when importing animation from studio max 2016, seems the root motion is not running at correct animation speed, however under studio max 2014 the speed is correct.