Download

4.11 preview 7 Stereo Panoramic export works!

Hi Gforman
I’m interested to see your plug, can you contact me please?
Thank you

Hi everyone,
I’m still struggling to maintain a fixed fps playing a level sequence while capturing a stereoscopic 360 video using Ue 4.14

I have a simple 300 frames at 30 fps level sequence with a camera moving forward.
When launching the stereo capture, first frame reads fine, but the animation keeps playing while the frame is being calculated
Ending up being way too early, in fact, the sequence reaches its end at the 3rd rendered frame …

I tried the many different solutions proposed in the forums various threads about it :

  • Launching Unreal Editor with a shortcut followed by -usefixedtimestep flag
  • Launching PIE as standalone with -usefixedtimestep in the advanced settings additional launch parameters
  • Using -usefixedtimestep as a console command ( even if I think it’s not supposed to work this way )
  • Setting the fixed frame rate directly in the rendering settings of UE
  • Setting the Forced fixed frame rate in the level sequencer general options
    Last thing I didn’t try was to cook the game and launch it with the -usefixedtimestep flag
    ( But I don’t think it would solve the problem as the editor seems to correctly get the fixed framerate as well, but doesn’t send it to stereo capture.)

I feel like I’m running out of options…
Has anyone successfully rendered a level sequence at a correct framerate with the stereo capture plugin inside UE 4.14 ?
Am I missing something ?
Thanks for your help.

Edit : Also posted on answerhub :
https://answers.unrealengine.com/questions/543770/ue414-stereo-pano-capture-level-sequence-fixed-fra.html

@ Ertayle

having the same problem with UE4.14.2. Any solutions?

Hi!
I just saw the video of @NeverEver575 and he doesn’t have a problem that I do have:
I just need screenshots, no videos, but the problem is that the glow from my windows (it is inside a plane) is giving me weird vertical bands, smaller as I make smaller the horizontal turning increment, but still there they are.
Also I am having 2 horizontal bands, I have tried changing the SP.VerticalAngularIncrement to about 30, but still nothing…
Does anyone know how could I get rid of that banding problem from the glow from the windows and the banding?
test.jpg

Thanks!

hey,

Post Process Lens Flare must be unchecked (value 0.0), cuz is not supported in stereopanoramic render.

hey,
@rayjaken, Post Process Lens Flare must be unchecked (value 0.0), cuz is not supported in stereopanoramic render.

Hi @Fredroxin! Thank you.

Lens flare are unchecked. This effect is Bloom effect, which is another one. There must be a way to get it working, this kind of glare, are @NeverEver575 does in his video, and also as you can see in Unreal blog where they explain how to use stereoscopic captures.

They show this effect in the fire, and I don’t know how to get it working fine… :frowning:

Did you tried SP.VerticalAngularIncrement Low than 30.0f? Actually i get good results with this parameters:

SP.HorizontalAngularIncrement 2.0f
SP.VerticalAngularIncrement 8.0f
SP.CaptureHorizontalFOV 30f
SP.ConcurrentCaptures 10
SP.StepCaptureWidth 2048
SP.ShouldOverrideInitialYaw false

Left_00001.jpg

OMG your model is amazing!

I have been tryinig with all kind of different values, and I don’t get to get rid of that effect… I will try with your specific values and check is it looks any better… Will let you know!

Thanks a lot!

Also, try to use a emissive only, sometimes a highest value in light intensity can generate issues.

pd: Ty! :smiley:

Thank you @Fredroxin! Some of your values is making my unreal crash… .I don’t know why. I have turned off bloom effect at the end :frowning:
One more question: does anybody know how to get rid of the poles effect, in the center up and down? You know, that kind os spiral effect like north pole and south pole in the image when you see it in VR… It is really annoying. I have seen surrounding images without that effect, so there must be a way to get rid of it… :confused:

Thanks!

Would this be possible while recording in VR mode? I’m not sure if it would be possible considering being in VR mode in editor while recording a panoramic video D:

When I run SP.PanoramicScreenshot the outputted images have the black channel completely translucent. Is this expected? I haven’t seen anyone else comment on this. Looking how to make it not translucent.

Edit:
The answer was in the 3rd post of this thread
SP.ForceAlpha 1

Adjusting that also fixed my “lighting” problem where the image looked dark(When I filled the background in). I find it strange opaque isn’t the default.

Hi…
If you use just one eye, left or right one, you have a monoscopic video. It will allways render both eyes, but in you video program just use one. But i have to say that immersion with VR video is only when in 3D. Otherwise it looks like painted on a wall and you can´t feel the height of objects also. So not a good idea without 3D. :wink:

This is definitely a issue for 4.14. In order to verify I downloaded 4.12.5 and created a new project. After doing all the settings the 360 movie capture works perfectly in 4.12. Then I converted this project to 4.14, and the problem came back…

Still don’t know how to fix it. I got the source code of 4.14 on github but it is too hard for me to fully understand… I might just work in 4.12 for now…

This is a issue with 4.14… I tried in 4.12.5 and it worked fine… And when I come back to 4.14 the problem happens again.

I tested on 4.15.0 Preview 4 and it worked just as fine as on 4.12! No frame skipping

Results: No frame skipping: 4.12, 4.15
frame skipping: 4.13, 4.14

Hi

I have been following the tutorial in the blog post and playing around with the panoramic plugin and for the most part it works fine.

But I was wondering if there is a way to generate Captures with Ambient Occlusion enabled in the PostProcessing volume? I can’t seem to get it working.
Would be really helpful if anyone has tried and could point in the right direction of how it works?

Hi.
Does anyone know how to control the tilt and yaw of the camera actor? no matter where i look with the camera it stays the same in the picture output with the plugin. It looks like it is fixed in one direction and you can´t control where to look at. Only x and y is transferred correct, but no luck with tilt and yaw. ;( Someone has luck with it?
Currently i am using 4.15, but 4.14 it was the same problem. I know it worked in 4.12 or 4.13 but now not anymore…Help please . :wink:

You can’t control this on a 360 camera. This would be like grabbing a person by the head and rotating it around. You should adjust the angle in post for scene transitions