4.10 iOS error - "Metal required but not available"

Tried launching my project in 4.10 which worked fine with 4.9 and get “Metal required but not available” error on (iOS 8), ipad air(iOS 9), and ipad air 2(iOS 8).

Hey ,

Thank you for noticing this issue with iOS Metal. We do have plans to fix this issue. However, we’re waiting on a response from Apple as the same code works built against the iOS 8 SDK and we have no validation errors when built against the iOS 9 SDK. So, our renderer implementation does not seem to be the issue. Our iOS developer will be testing the latest iOS 9 Beta today or tomorrow with a potential work-around which leaves metal on.

Thanks!

curios if there has been any more progress on this issue as i am currently getting the pop up on my iPad air (iOS 9.1)

,

I just spoke with our iOS Developer and he has verified that this fix will be coming very soon.

Do you know when this is going to be fixed? Metal still doesn’t work with 4.11 preview 4.

This should have been fixed in 4.10.1 could you please provide me with your full reproduction steps?

Thanks! :slight_smile:

Ok the problem seems to be with iOS 8. I re-downloaded 4.10.2 and created a new project. These are results when launching to 3 different devices.

uncheck Supports Open GLES2 & set MinimumiOS version to 8
– (iOS 8.4.1), ipad air 2(iOS 8.1) - “Metal required but not available”. ipad air(iOS 9)- works

Forward rendering with Metal & Open GLES2 both checked
– (iOS 8.4.1), ipad air 2(iOS 8.1) - both crash right away with no message

Thanks for providing me with this information. I am looking into this issue further and I will respond once I have solid information.

Thanks!