Download

(39) Rama's Extra Blueprint Nodes for You as a Plugin, No C++ Required!

Great to hear from you Nsomnia and thanks for helping out in the thread!

I’ve just compiled a new version and we’ll see if that works well for everyone!

Rama

4.8 Again

Dear Community,

It sounds like the version that got uploaded on June 10th was not the version I upgraded to 4.8, because I fixed all the compiler errors that Nsomnia posted here (thanks for helping out Nsomnia!)


**4.8 Upload, June 11th**

****I've uploaded my plugin again for the 4.8 build!****

I am definitely using the release version of 4.8, not a custom engine build.

Let me know how it goes!

**Latest plugin download is here: (about 8 mb) **

Enjoy!

:slight_smile:

Rama

HasSubstring, returns whether one string is a substring of another!


(as of 6/11/15)

Dear Community,

I’ve made a new BP node for you!

HasSubstring compliments the functionality of FindSubstring.

FinsSubstring requires more inputs and returns an index within the source string.

My node, HasSubstring, requires only 1 input and only returns whether or not the supplied substring is in the source string.

I use the C++ version of HasSubstring all the time so I felt you would all enjoy having it in BP as well!


**Example Usage ~ Search Feature**

If you wanted to make a string-based search feature, that iterated over the contents of a list of UMG Texts, you can take the user's supplied search string and use my **HasSubstring **node to find all the UMG Text widgets that contain the user's supplied search string.

**Latest plugin download is here: (about 8 mb) **

Enjoy!

:slight_smile:

Rama

I still get this error even with your new upload.

MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: [11/12] Link UE4-VictoryBPLibrary.lib
MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: [12/12] Link Project542352352.exe
MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: LINK : fatal error LNK1181: cannot open input file ‘C:\Program Files\Unreal Engine\4.8\Engine\Intermediate\Build\Win64\UE4\Development\Launch\PCLaunch.rc.res’

Amazing work

Are you sure your in development or debug game for your solution configuration?

I’ve had issues with anti-virus/anti-malware in 4.8 with compiling a couple projects and heard similar.

The has substring node will be great! Mix it up with Get display name or get class -> get display name and you have a very powerful search ability/way to build logic based off classes in an inventory/crafting/equip system.

@Tekopper

This error seems related to packaging?

Are you trying to package the game when this occurs?

Is your project BP-only?


**I Did a BP-Only Packaging Just Fine**

1. I just made a BP-only game, third person template, 
2. Copy and pasted my plugin into the project-level plugsin directory, 
3. and packaged with no issues! (I did have Full Rebuld checked)

Potential Solution:

When you package, make sure you do a full rebuild each time!

File -> Package Project -> Build Settings -> Full Rebuld



MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: [11/12] Link UE4-VictoryBPLibrary.lib
MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: [12/12] Link Project542352352.exe
MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: LINK : fatal error LNK1181: cannot open input file 'C:\Program Files\Unreal Engine\4.8\Engine\Intermediate\Build\Win64\UE4\Development\Launch\PCLaunch.rc.res'


_


Great to hear from you tjaunreal!

Yay! I’m glad you like my new HasSubstring node Nsomnia!

:slight_smile:

Rama

Hi Rama,

As I mentioned before, I got the June 10th update working, but the one from the 11th appears to be the same file as the one from the 10th. The folders are exactly the same size, down to the byte. Also, do you know why the new uploads aren’t showing on the main list? (I have to delve into the file history for them to show up: http://puu.sh/ilHXw/9ee6014696.png )

Anyway, thanks for the repeated updates and communication, we <3 you!

Wiki Download Page Issues

Dear Anaklu,

That’s really odd!

Here’s what I see

503ba7f9cdf32d8c7ce2b55d2f230ca5491ffefa.jpeg

Here’s what Community Member Anaklu sees

http://puu.sh/ilHXw/9ee6014696.png

Epic can you fix this somehow?

This explains why people are saying my 4.8 upload is updated for some and others say it is not updated!

Thanks!


**Here's the link to the wiki page in question**
https://wiki.unrealengine.com/File:VictoryPlugin.zip

:)

Rama

Media Fire Download That Is Up To Date

Dear Community,

Until the issue with the wiki download system is resolved, I’ve put the latest version of my plugin up on MediaFire!

You can ensure you have the latest version by using this download link!

Please note clicking this link will not start a download instantly, it will just take you to the Media Fire file.

Victory Plugin on Media Fire
(6/11/15 build from Wiki, 7.91 mb)


**Epic Wiki Link**

**Latest plugin download is here: (7.91 mb) **
https://wiki.unrealengine.com/File:VictoryPlugin.zip


Enjoy!

Rama

Thanks Rama! Downloaded and updated to the newest version. Man, that made me feel like a crazy person. Glad it’s all figured out now :slight_smile:

Hi I can confirm I was seeing the same thing. I will try the new link.

Thanks

Yeah Rama it’s blueprint/content-only project with full rebuild on, I got the same error on a new project. But it only happens when I’ve got your plugin enabled. I even tried reinstalling 4.8 and tried a new project again, same thing.

Edit: Appears I’m not alone with that link error. Packaging is failing in 4.8 - UE4 AnswerHub

Hey quick question, I’m installing the plugin step by step but it just doesn’t work in the editor. It shows up on the plugin list, it’s enabled, config line is added, editor restarted… I tried it on different computers, same effect, cannot find any errors etc.
I used an older version of VP couple builds ago and it worked fine. Thanks for any advice!

The june 11th 7.91mb version shows up fine on the website, and loads/runs/etc. just fine in both C++ and BP based new and old projects for me.

As to the linking errors. I only got those when I had bad code as in errors, and to the response on that thread “I disabled the substance plugin” I have the 4.8 substance-ue4 plugin installed in all my projects :S

I guess the wiki link was still broken when I downloaded it or something, tried it now with the mediafire link and it compiles fine.

Just tested downloading the 11th june 7.91mb version from the wiki and from the mediafire and the mediafire one appears to be newer then the wiki one, it’s files are bigger and have newer dates then the wiki one.

Edit: Just tried it again with both links on new projects and now I suddenly can’t get it to work again.

Edit2: Found out that if I verify my 4.8 version I can package new projects until I attempt to package my 4.7.6 project which somehow breaks it for all projects.

I’m having no problems with the wiki link on fresh projects or old. Make sure you select engine version -> 4.8 on any old projects first, and try deleting ALL intermediate folders, or are you talkuing about just linking errors?

These are very strange errors indeed!

Please post on Answerhub about this!

It sounds like it could be related to the new unification of all Editor Settings across all projects (and apparently all versions?)

:slight_smile:
Rama

Welcome ot the forums Ozzie!

“Hey quick question, I’m installing the plugin step by step but it just doesn’t work in the editor”

Can you explain more? What’s not working? BP nodes not showing up or the vertex snap editor not working?

Please make sure you are using 4.8 and download from my Media Fire link due to issues with wiki download system for some people / browser cache stuff

You can ensure you have the latest version by using this download link!

Please note clicking this link will not start a download instantly, it will just take you to the Media Fire file.

Victory Plugin on Media Fire
(6/11/15 build from Wiki, 7.91 mb)

Have fun today!

Rama


(as of 6/11/15)

Reminder of my new node that I just released amidst all the support posts :slight_smile:

Dear Community,

I’ve made a new BP node for you!

HasSubstring compliments the functionality of FindSubstring.

FinsSubstring requires more inputs and returns an index within the source string.

My node, HasSubstring, requires only 1 input and only returns whether or not the supplied substring is in the source string.

I use the C++ version of HasSubstring all the time so I felt you would all enjoy having it in BP as well!


**Example Usage ~ Search Feature**

If you wanted to make a string-based search feature, that iterated over the contents of a list of UMG Texts, you can take the user's supplied search string and use my **HasSubstring **node to find all the UMG Text widgets that contain the user's supplied search string.

**Latest plugin download is here: (about 8 mb) **


You can ensure you have the latest version by using this download link!

Please note clicking this link will not start a download instantly, it will just take you to the Media Fire file.

**Victory Plugin on Media Fire**
(6/11/15 build from Wiki, 7.91 mb)

https://www.mediafire.com/?g6uf9kt5ueb2upj

Enjoy!

:)

Rama