Download

(39) Rama's Extra Blueprint Nodes for You as a Plugin, No C++ Required!

So the Objects to be spawned with your “Create UObject” Node should be parent class object instead of Actor, right?

How to use your plugin with a version you haven’t compiled it for? Like the most recent 4.7 branch?

Thanks Rama, my project compiled on both Linux and Android!

Hey Rama,

I love your plugin - I wish Epic would think strongly about integrating many of your features.

I do, though, wish that the Get Config Var nodes had an Output Bool variable as to whether the variable was actually found. I plan on modifying your plugin with this for my use but it might be useful for everyone.

Edit: This was easy to do, just added a new bool& IsValid to the method and then set it to the output of the GConfig Get methods.

Cheers,
Josh

Hi Rama, using your fab plugin to create instanced meshes from many SM but I run into a problem on built/cook game, any Instanced Mesh is missing from the game on launch, everything else is fine. This doesnt happen in PIE but does happen when running “Standalone” mode also. I use UE4.7.3, any ideas?

I’m kinda happy to see this, because at least I’m not going crazy, as that’s the problem I have too.

Wooohoooo! Yay! Glad my fixed work! Epic RCL helped!

Congratulations on your first post Joshy! Welcome to the forums! :slight_smile:



[QUOTE=John Alcatraz;257011]
So the Objects to be spawned with your "Create UObject" Node should be parent class object instead of Actor, right?

How to use your plugin with a version you haven't compiled it for? Like the most recent 4.7 branch?
[/QUOTE]


You can add code to your project if it is BP only, adding just a simple empty actor class.

Once 4.8 comes out this will most likely be unnecessary so you might just want to wait till then.

My plugin is up to 4.7.3 now though!

**Most Recent Victory BP Plugin Download**
https://wiki.unrealengine.com/File:VictoryPlugin.zip

:)

Yes I need to look into this, it is a problem with the instanced static mesh component itself and may require engine modification, I am not sure yet. But yes I am aware of the issue!

Have fun today!

:heart:

Rama

Thank you so much for this Rama, I’ve tried for so long to get the closest point on a surface relative to the players location, was just a big mess. After a while I found your article with the script and though I could expose that as a function myself, that ended up in a bigger mess. I thank you from the bottom of my heart. You are a truly good and helpful person. I really hope EPIC gets their stuff together and starts implementing more functions for Blueprints as they’re lacking.

Why do you talk about adding code to the project? I asked which parent class BPs should have to being able to get spawned with “Create UObject” :slight_smile:

I know your plugin is up to 4.7.3 now, but often I need to use the most recent 4.7 branch because of some fixes and then I can’t use your plugin. I can’t just wait for 4.7.4 or 4.8 to have the fixes since I sometimes need them to being able to continue working on my game. So how can I use your plugin with a version you havent it specifically compiled for? Can I compile it myself for the most recent 4.7 branch?

Well you could try to just compile them, but that depends on the changes made to the branch. If you’re lucky, nothing will break, but otherwise you will most likely have to fix some code pieces yourself. That’s as far as I understand it.
I used always used the latest plugin version with 4.7.3, so I was surprised to see that Rama updated it for 4.7.3, since I just used an earlier version with 4.7.3 and had no issues. But since 4.8 has bigger changes I assume that this method wouldn’t work as easily as any 4.7.x version.
I hope what I said is correct ^^

Greetings,
Dakraid

I often tried to use the 4.7.3 version with the latest 4.7 branch or before to use the 4.7.2 version of plugin with 4.7.3 from github and it never worked, project will not load up until I remove the plugin from the folder.

Hello Rama! Thanks for the victory plugin. Works great in the editor but when I hit Launch, this error pops up. I wrote the command line to the config, double checked in the plugin window if it’s enabled. Everything’s fine. I don’t understand why this happens.

Also, I don’t know if you ever encountered, in another map, the merged static meshes’ shadows are constantly on and off and when I undo the merging it’s ok. I couldn’t test it if it’s the same when I launch the game because of the main error. So I’ll be grateful if you can help me.

here’s the error:

1a601fe175c6f073a5632db1c21b0ec4267d4930.jpeg

1>EXEC : error : Exception thrown while processing dependent modules of VictoryBPLibrary

Have you seen this Rama? I’m trying to build Linux dedicated server. Hmmm…

Wow, we keep you too busy on here! Sorry about that. Not quite sure if this is a general problem with the engine or the plugin. I searched for a while and found no information.

I commented out
“UnrealEngine-4.7.2-release\Engine\Source\ThirdParty\libPNG\UElibPNG.Build.cs”
lines 61-66 to avoid
“if (Target.Type == TargetRules.TargetType.Server)”
Will see if that works…

Thanks!

Looks like you didn’t put the plugin files into your project correctly. If you read back on these forum posts you’ll likely find your answer.

That’s wild that there is so much effort to avoid UELibPNG in dedicated server builds!

The ultimate culprit is the inclusion of ImageWrapper in VictoryBPLibrary.build.cs



public VictoryBPLibrary(TargetInfo Target)
	{
        PublicDependencyModuleNames.AddRange(
			new string] { 
				"Core", 
				"CoreUObject", 
				"Engine", 
				"InputCore",
				
				"RHI",
				"RenderCore",
				 
				"HTTP",
				"UMG", "Slate", "SlateCore",
				
				"ImageWrapper",
				
				"PhysX", "APEX" 
			}
		);


You should not need image wrapper on dedictated server, in fact, it seems you should figure out which of my BP nodes you really need on a dedicated server and make a special version of my plugin that reduces dependencies and module inclusions to a minimum. For starters you could remove all of the nodes that use the image wrapper and remove the ImageWrapper from build cs and see how far that gets you!


#If Compiler Paths

You can avoid having to make a separate version of the Victory BP library by simply commenting out stuff at the compiler level that you dont want to include in a dedicated server build.

Wrap stuff you want to exclude from dedicated server version with this:



```


#if !IS_DEDICATED_SERVER
//bp node code in .h and .cpp to exclude from dedicated server builds
#endif //IS_DEDICATED_SERVER


```




This essentially gets you two different builds of the plugin in one set of files!

Might be a bit tricky with some of the #includes but let me know how far you get! (sorry really busy and cant quickly test dedicated server builds right now, but if you get something stable going would love for you to share it with us all)

Enjoy!

Rama

Thanks Rama, I really appreciate your time. I know how it goes when many people ask questions. I will let you know how it goes. For now I just commented the if (Target.Type == TargetRules.TargetType.Server) statement in UElibPNG.Build.cs and see where that gets me. I’m not too worried about performance at this point.

Rama, I’m updating a project to 4.7.3 and I snagged your March 25th build, but it says

Capture.JPG and than fails to build.

Any thoughts?

Do you have visual studio community installed? Someone in my group had a problem with VS Community and switching to Express worked for him. I had a problem with Express and switched to community. In both cases I imagine a simple re-installation may have fixed our problems.

Hello Rama,

first I want to say thank you for sharing your tools with us !
I think, the vertices snapping function is my favorite function in all UE4 now.

But I have found 2 issues if I am not wrong about it.
First issue : I create an ISM of the testlevels walls and ground, which have all dynamic shadows disabled. but if I create an ISM of them, I get this message, which tells me, that the ISM still creates dynamic shadows, and I can’t change it.

87781648dcbd6c6fdae59dd882d98a4789c9432c.jpeg

Second thing is about ISMs too, I created an ISM containing all the walkways meshes of the map, but
they get not all contained just inside the ISM they also seem to be seperate objects aswell. If i select the ISM I
visually only select one mesh of the walkway, but can move the complete ISM until I move one of the still seperate looking
(but marked as part of the ISM while I created the ISM) meshes. After that, the ISM contains only the one mesh of the walkway,
which is named by the ISM tag. Obviously the ISM can’t always be created out of all selected meshes.

9b54d7eed0891b388f644fcb9d6d23d05fe8c039.jpeg

I hope this info is useful.

Edit :
btw. how does that vertice rezising work in detail, if I select one vertice with v and press + nothing happens.

I get this error when launching directly - the VS project compiles fine in VS, but when I try to launch I get this error and rebuilding these files fails. It acts like I’m using the wrong version of the plugin but I downloaded the latest one. Really odd.

Edit: looks like it may have been a corrupt file in my project unrelated to this plugin. I reverted to a previous save and it plays nicely again.

@Hyperloop
I had that happen with VS studio somehow. I don’t think it’s a problem with the plugins but more a problem with the editor. Can you try a different plugin and see if it compiles? I use VaRest which works fine for me on 4.7.2 (I imagine it works fine on 4.7.3) Maybe you can use that to test? If VaRest doesn’t work I’d say try reinstalling VS. But that’s all I have experienced. Maybe someone else will know more.