Download

3 Way Blueprint Camera Transition Issues (Originally by TheWisdomcube2000)

TheWisdomcube2000 a while back posted his camera transitions and followed that up with providing snippits of the blueprints that ran it.

I followed his youtube videos and screenshots and it just wont work!
Here’s an album of screenshots of what I have:

And here’s a link to his post:

What am I doing wrong? I have TAB setup as my camera switch button and when I press it nothing happens except I’m told what camera I’m in…it wont switch it. Actually, on start the camera isn’t even in one of the three locations I have set… Any help would be appreciated.
Thanks!

Where you set the Enum variable at the end of your logic chain is incorrect.

It should be set to the next camera perspective type along, not set to itself.

Go back over the video where he shows his blueprint setup, you will notice his Enum set nodes are set to the next camera perspective type at the end of each logic chain.

I love you! Ok, so now it switches but the camera doesn’t react at all. it just sits in the position that it shows in the view-port where you can physically arrange the camera. any thoughts? Ive been playing around with sockets and the boom but nothing gets it to even nudge unless i move it myself…

You need to pay more attention to detail.

Go back over the video, you are missing some key settings on particular nodes.

you’re right i do! lol I went through, cleaned up a bunch of stuff and got it to work. Thank you!!