Download

2d capture actor clear to green instead of black

I’m wondering how to set a 2d capture actor to clear to green instead of black when things are outside the clip plane?

You can set the clear colour of the render target.



UTextureRenderTarget2D::ClearColor


But not the scene capture component I believe. You may have to manually clear the render target before filling it from the capture component again, to see the clear colour outside of the clip plane.

I have poked at this with no success. Setting the ClearColor of the rendertarget doesn’t seem to help and everywhere i’ve attempted to manually clear hasn’t made any difference.