Download

2D Blocky Sprites

Thanks to help from Fuchs, I was able to resolve our scene being desaturated. There are a few redundant settings for auto-exposure and lighting that you have to hunt around for. Now we are back to a fundamental problem that we have been ignoring. Blocky sprites. We moved from Game Maker into Unreal (for obvious reasons) and the sprites have not been rendering correctly since day one.

  • I’ve set the AA the FXAA.
  • We have the game quality set to maximum.
  • 60FPS
  • I’ve tried setting the texture to bi-linear.
  • I’ve tried a variety of mask settings on the sprites.

This is a picture. The edges both on the sprite standing in the middle and the environment, are not supposed to be blocky.

edge.png

So it seems that I am using the wrong material for the sprites, AND, you need to set the correct material on the animations as well.

https://answers.unrealengine.com/questions/164288/blocky-sprite-edges.html