2 versions of Unreal, contantly having to clone only to lose project.

For some reason in my Epic Games pre-Unreal thing, I can run both Unreal 4.9.2 and 4.7.6.
I have no need for 4.7, how do I remove it?

The more pressing issue is the fact every time I try to open my 4.9 project, it says it has to clone it, and the past 2 times it’s loaded up a blank project with no assets.
I’m getting into creating my final year project and can’t have Unreal giving me silly issues like this. How can I fix all of this and get a version that isn’t going to ruin my life?
Thanks

To uninstall a version, hover over its tab in the launcher and you’ll see an ‘x’ appear in the top left corner.
That’ll uninstall it.

In my experience, it is only templates that are cloned.
I am unsure why any your own projects would be cloned.
Are you opening an old version of your project with a new version of UE4?

The current release of UE4 is 4.10.2.
To add this, click on the “Add Versions” button in the launcher.

They have changed pre-compiled engine install directory; I have installed all versions since 4.0.
The engine was installed in “Unreal Engine” folder, now it is in “Epic Games” folder.
If it fail to remove from the launcher, look into those program files folders for the “4.7” folder and remove it.

Thanks all, as Kris suggested I just deleted the old version, and all of my problems were solved. Cheers :slight_smile:

No problem.
I’m glad it all worked out.