Download

1st person blueprint / trigger volume collision

I added a basic trigger volume to the level and the projectiles collide with it by default. How do I remove the collision between the projectiles and the trigger volume? I tried to find where such collision would be defined in the project, but was unsuccessful. Thank you.

Hello,

If your trigger is in a level, then you have the detail panel on the right with collison presets.
If it is in a blueprint, detail panel is on the left.

If it is only a specific collision trigger / projectiles you’ll have to set it with blueprint by comparing other actor on event.

I was aware of where the details are for the trigger volume, but I am glad you mentioned it, as it made me revisit the options.

A more detailed answer to my question is to set the “Collision Presets” to “Custom” and then work the check boxes below so that projectile is ignored, along with any other desired behavior. For each object type presented you can ignore any collision responses, continue to tap into overlap events or block the object which of course makes it repel off the volume (which is what I wanted to prevent, so I chose to ignore for projectiles).

Thank you.

Even more detailed, in the Custom settings you want to set ‘Object Type’ to ‘Pawn’ and then change all Object Responses to ‘Ignore’ except ‘Pawn’.