User Tag List

Page 2 of 15 FirstFirst 123412 ... LastLast
Results 41 to 80 of 567

Thread: 5/9: ARK Dev Kit v257.45 has been posted to the Epic Launcher!

  1. #41
    0
    Avter Epic Games Launcher still old Map and its the SotF Map !

  2. #42
    0
    Promoter
    Join Date
    Jul 2015
    Posts
    151
    Quote Originally Posted by Finntastic View Post
    The Pachy, Frog and Trilobite are missing textures, does anyone has the same problem?
    Yep, does not seem to hinder anything in game thank god... The animations in the PIE are also screwed up as the character always runs when on a dino....
    DinoOverhaul X CLICK HERE

  3. #43
    0
    Unreal Engine Partner
    Join Date
    Mar 2015
    Posts
    205
    Sorry about that mix-up! We've posted non-crashing v224.5 binaries to GitHub (this was also an issue which affected the general game release and has since been fixed), and linked the correct v224 content in the original post. If someone can try them and confirm they seem to work alright, then we'll go ahead and get the Epic Launcher updated as well:

    "ARK Dev Kit v224.4 has been posted to the Epic Launcher!
    However, you'll want to install this corrected content over it: https://drive.google.com/file/d/0B0d...ew?usp=sharing
    And these v224.5 Binaries, via GitHub, to fix a crash case: https://github.com/StudioWildcard1/Ark-Dev-Kit"

    We really appreciate it!

    -Drake

  4. #44
    0
    The last patch also seems to have made my pawn eternally sprint in place.

  5. #45
    0
    Unreal Engine Partner
    Join Date
    Mar 2015
    Posts
    205
    Quote Originally Posted by hogscraper View Post
    The last patch also seems to have made my pawn eternally sprint in place.
    Are you running v222.5 binaries from GitHub/content from Google Drive? Everything seems to be good with those for us...

  6. #46
    0
    Promoter
    Join Date
    Sep 2015
    Posts
    255
    i will be updating manually in just a moment drake. Ill let you know how it works for me

  7. #47
    0
    Promoter
    Join Date
    Sep 2015
    Posts
    255
    Speaking of, is there a proper order in which to copy over first? Binaries then differing content? or the other way around?

  8. #48
    0
    Unreal Engine Partner
    Join Date
    Mar 2015
    Posts
    205
    Quote Originally Posted by jslay View Post
    Speaking of, is there a proper order in which to copy over first? Binaries then differing content? or the other way around?
    Doesn't matter which, as they affect different files (GitHub and the Google Drive ZIP).

    Thank you so much jslay. The GitHub + Google Drive content seems good to us here (i.e. no crashes or animation problems and correct latest content), but once confirmed by someone from the community, we'll get the Epic Launcher updated.

    Cheers,
    Drake

  9. #49
    0
    Promoter
    Join Date
    Sep 2015
    Posts
    255
    Getting a crash when compiling, but the cooker keeps going. So Im gunna let it finish, kick it off again, and get a screenshot for you.

    Code:
    Ensure condition failed: bValidRootIndex [File:F:\UE4\UnrealEngine\Engine\Source\Runtime\Engine\Private\Animation\AnimBlueprintGeneratedClass.cpp] [Line: 219] 
    
    
    
    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff
    
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f4eb92a) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f4eca57) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f4f0b2b) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f4d2601) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f4de4b1) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1a6354) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1ed7cd) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1023fa) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff7563fa821) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff7563fa715) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff7563fce42) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff7563fed44) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff7563fed7a) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff75640ab40) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff75640ba79) + 0 bytes [UnknownFile:0]
    KERNEL32.DLL!UnknownFunction (0x00007ff86b378102) + 0 bytes [UnknownFile:0]
    ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]
    ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]
    Doing a verify with the launcher to see where that gets me. This will take some time.
    Last edited by jslay; 11-29-2015 at 06:44 PM.

  10. #50
    0
    Promoter
    Join Date
    Sep 2015
    Posts
    255
    Also, it would be really nice if there would be a way to get tribe ownership information off what an admin is looking at so that they can set the ownership of stuff properly without making it personal owner when they do give all structure/ give to me.

    Structure ownership can be a real pain when transferring tribes or something like that and if it gets messed up, not much anyone can do but destroy, replace mats, and rebuild. Unless I am missing something.

  11. #51
    0
    Promoter
    Join Date
    Sep 2015
    Posts
    255
    Compiled fine after verifying, Replacing with new files and trying again. And yes, cont walking ani was fixed.

    New files in place. Cooking mod now...



    This also crashes PIE

    First Crash
    Code:
    Ensure condition failed: bValidRootIndex [File:F:\UE4\UnrealEngine\Engine\Source\Runtime\Engine\Private\Animation\AnimBlueprintGeneratedClass.cpp] [Line: 219] 
    
    
    
    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff
    
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f53b92a) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f53ca57) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f540b2b) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f522601) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f52e4b1) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1a6354) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1ed7cd) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1023fa) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c6a821) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c6a715) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c6ce42) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c6ed44) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c6ed7a) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c7ab40) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c7ba79) + 0 bytes [UnknownFile:0]
    KERNEL32.DLL!UnknownFunction (0x00007ff86b378102) + 0 bytes [UnknownFile:0]
    ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]
    ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]

    Second Crash (appears to be the same as first):
    Code:
    Ensure condition failed: bValidRootIndex [File:F:\UE4\UnrealEngine\Engine\Source\Runtime\Engine\Private\Animation\AnimBlueprintGeneratedClass.cpp] [Line: 219] 
    
    
    
    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff
    
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f53b92a) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f53ca57) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f540b2b) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f522601) + 0 bytes [UnknownFile:0]
    UE4Editor-RenderCore.dll!UnknownFunction (0x00007ff84f52e4b1) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1a6354) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1ed7cd) + 0 bytes [UnknownFile:0]
    UE4Editor-CoreUObject.dll!UnknownFunction (0x00007ff83a1023fa) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c6a821) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c6a715) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c6ce42) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c6ed44) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c6ed7a) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c7ab40) + 0 bytes [UnknownFile:0]
    UE4Editor.exe!UnknownFunction (0x00007ff791c7ba79) + 0 bytes [UnknownFile:0]
    KERNEL32.DLL!UnknownFunction (0x00007ff86b378102) + 0 bytes [UnknownFile:0]
    ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]
    ntdll.dll!UnknownFunction (0x00007ff86d42c264) + 0 bytes [UnknownFile:0]
    Verifying again to get back to a good build.
    Last edited by jslay; 11-29-2015 at 07:50 PM.

  12. #52
    0
    Unreal Engine Partner
    Join Date
    Mar 2015
    Posts
    205
    Try getting the latest binaries from GitHub (still referred to as v224.5). One of the 'uplugin' files was out of date, which was messing it up to cause that crash. Please let us know how it goes, thanks!

    -Drake

  13. #53
    0
    Promoter
    Join Date
    Sep 2015
    Posts
    255
    Will do once it finishes verifying. :P

    Want to have a fresh good build to upgrade from.

  14. #54
    0
    Unreal Engine Partner
    Join Date
    Mar 2015
    Posts
    205
    Quote Originally Posted by jslay View Post
    Will do once it finishes verifying. :P

    Want to have a fresh good build to upgrade from.
    Thank you

  15. #55
    0
    Promoter
    Join Date
    Jul 2015
    Posts
    151
    Quote Originally Posted by StudioWildcard View Post
    Try getting the latest binaries from GitHub (still referred to as v224.5). One of the 'uplugin' files was out of date, which was messing it up to cause that crash. Please let us know how it goes, thanks!

    -Drake
    Drake, please look into the penguin, angler, and deepwater spawner that the (Plesio is mapped to); when they are remapped with a copied version of those spawners they never stop spawning dinos, i had 80k angler fish and 20k penguins on the map, i had to remove the mapping of those spawners and just remap the NPCs.

    As for the current build i will be testing here in 10min
    DinoOverhaul X CLICK HERE

  16. #56
    0
    Promoter
    Join Date
    Sep 2015
    Posts
    255
    Crashes appear to be fixed, but getting the cont walking ani again. (Which I can deal with)

  17. #57
    0
    Unreal Engine Partner
    Join Date
    Mar 2015
    Posts
    205
    Quote Originally Posted by M1k3_C View Post
    Drake, please look into the penguin, angler, and deepwater spawner that the (Plesio is mapped to); when they are remapped with a copied version of those spawners they never stop spawning dinos, i had 80k angler fish and 20k penguins on the map, i had to remove the mapping of those spawners and just remap the NPCs.
    Yeah for now, those spawners (and the mosasaurus spawners) are set to specifically limit those classes of dinosaurs, so the Spawner Remapping would cause problems unless you are explicitly also remapping those NPC's. We'll look into handling it a bit differently for those spawners to allow them to be more broadly remapped. But we have an even better system coming up next week: the capability for Mods specifically, to override OR add new sublevels of 'TheIsland' -- which will allow Mod authors to directly revise or enhance whatever aspects of TheIsland they choose without limitation! (currently only a TC or entirely new map can effectively do this)

    -Drake

  18. #58
    0
    Unreal Engine Partner
    Join Date
    Mar 2015
    Posts
    205
    Quote Originally Posted by jslay View Post
    Crashes appear to be fixed, but getting the cont walking ani again.
    I think that's because Verifying with the Epic Launcher would have clobbered your Content files (if you extract them once again from the zip they should be fine). Seems like we're good, we'll go ahead and get the Epic Launcher updated asap

  19. #59
    0
    Promoter
    Join Date
    Jul 2015
    Posts
    151
    Drake,
    The animations seem to be fine, but as you can see by this screen shot http://postimg.org/image/7e3ndbpmd/full/ the meshes are still not showing correct and those dinos do not work correctly in PIE.
    DinoOverhaul X CLICK HERE

  20. #60
    0
    current github files and content are doing this while compiling. Name:  Capture.JPG
Views: 637
Size:  91.2 KB

    Current as of a couple hours ago. Also just tried compiling other projects and they failed with the same error as well. Redownloading github files right now to ensure I have the newer ones.
    Last edited by hogscraper; 11-29-2015 at 08:58 PM.

  21. #61
    0
    Unreal Engine Partner
    Join Date
    Mar 2015
    Posts
    205
    Quote Originally Posted by hogscraper View Post
    current github files and content are doing this while compiling. Name:  Capture.JPG
Views: 637
Size:  91.2 KB

    Current as of a couple hours ago.
    Hogscraper, we just updated the GitHub files < 1 hour ago with the fix for that, as far as I can tell.

    M1k3_C, that is due to the content in the Epic Launcher being oudated. If you extract this content over it, it should work:
    https://drive.google.com/file/d/0B0d9jibPVqYzd2Z3eU5PVmJlckE/view?usp=sharing


    I think we need to get the DevKit on the Epic Launcher updated to ensure everyone is in sync

    -Drake

  22. #62
    0
    Promoter
    Join Date
    Jul 2015
    Posts
    151
    Quote Originally Posted by StudioWildcard View Post
    Hogscraper, we just updated the GitHub files < 1 hour ago with the fix for that, as far as I can tell.

    M1k3_C, that is due to the content in the Epic Launcher being oudated. If you extract this content over it, it should work:
    https://drive.google.com/file/d/0B0d9jibPVqYzd2Z3eU5PVmJlckE/view?usp=sharing


    I think we need to get the DevKit on the Epic Launcher updated to ensure everyone is in sync

    -Drake
    Drake, that is what i downloaded, as well as the latest binaries. Once you open the primalgamedata it does that to those specific dinos, try it for yourself you will see what i mean. As for the compiler it works just fine.
    Last edited by M1k3_C; 11-29-2015 at 09:03 PM.
    DinoOverhaul X CLICK HERE

  23. #63
    0
    Quote Originally Posted by StudioWildcard View Post
    Hogscraper, we just updated the GitHub files < 1 hour ago with the fix for that, as far as I can tell.

    M1k3_C, that is due to the content in the Epic Launcher being oudated. If you extract this content over it, it should work:
    https://drive.google.com/file/d/0B0d9jibPVqYzd2Z3eU5PVmJlckE/view?usp=sharing


    I think we need to get the DevKit on the Epic Launcher updated to ensure everyone is in sync

    -Drake
    Thank you Drake! I can confirm that newest files are compiling fine. Sorry about the mixup.

  24. #64
    0
    Quote Originally Posted by StudioWildcard View Post
    I think that's because Verifying with the Epic Launcher would have clobbered your Content files (if you extract them once again from the zip they should be fine). Seems like we're good, we'll go ahead and get the Epic Launcher updated asap
    Hey Drake, I've tried updating with the latest content, and Github, but no luck. Character keeps running in place. Any tips?

    Thanks,
    Rexcidium
    Last edited by Rexcidium; 11-29-2015 at 10:36 PM.

  25. #65
    0
    Quote Originally Posted by Rexcidium View Post
    Hey Drake, I've tried updating with the latest content, and Github, but no luck. Character keeps running in place. Any tips?

    Thanks,
    Rexcidium
    My pawn is also running in place but I did a test project and uploaded it with no auto-running in game. Looks like its something only in the editor for me.

  26. #66
    0
    @hogscraper

    Did you happen to notice in your test project if the textures of e.g. Triobite are "missing"? Seeing as they don't work for me in the editor.

  27. #67
    0
    Unreal Engine Partner
    Join Date
    Mar 2015
    Posts
    205
    v225.4 content and code is all updated onto the Epic Launcher now, should be good to go without issues now if you update and verify all in the launcher

    Cheers,
    Drake

  28. #68
    0
    I am confused, the title says 224.6 but you saying v225.4 but I just updated on the launcher and the devv kit says 224.5. So which one am I suppose to be on?
    Mod Creations for Ark Salcarr's Workshop.

  29. #69
    0
    Thanks for the effort Drake! All works well again!

  30. #70
    0
    Quote Originally Posted by salcarr View Post
    I am confused, the title says 224.6 but you saying v225.4 but I just updated on the launcher and the devv kit says 224.5. So which one am I suppose to be on?
    salcarr, if you just verify via the Epic Games Launcher, you'll have the right version. (224.5 in the ADK)

  31. #71
    0
    I have the 224.5, but if that is the right version why does the title say 224.6 and then Drake saying 225.4 unless that was just an error on text? I just want to be sure I am on the right version lol
    Mod Creations for Ark Salcarr's Workshop.

  32. #72
    0
    Drake's infamous for typos, from the posts I've read of his here and on steam lol.

    The version number in the DevKit doesn't always change, technically the DevKit could be a 24.6 but minor revisions aren't of that much consequence.

    -WM
    Workshop: My Workshop
    ARK Modding Discord Admin: Join here!

  33. #73
    0
    Any news when there will be v.226?

  34. #74
    0
    Is anyone else having issues with 224.5 cooking BASE_PrimalGameData_BP into a TC when it hasn't been changed at all ? I don't get the latest engrams cause its cooked the 224.5 version. I've verified my devkit on the launcher and redone my changes fresh but its still the same

  35. #75
    0
    Quote Originally Posted by KieronB View Post
    Is anyone else having issues with 224.5 cooking BASE_PrimalGameData_BP into a TC when it hasn't been changed at all ? I don't get the latest engrams cause its cooked the 224.5 version. I've verified my devkit on the launcher and redone my changes fresh but its still the same
    That's the entire point, and the drawback, of Total Conversions. They replace the files the clients/server uses.

    The PrimalGameData's in the DevKit don't contain the content of the 226.3(Live clients) PrimalGameData's so they will not show up. This is why core-data mods and TC's especially need to be updated with DevKit updates... it's also why people constantly ***** on steam when a TC locks out content when they don't realise that modders have no say, sway or power to do anything. We're at the mercy of Wildcard and their release schedule.

    -WM
    Workshop: My Workshop
    ARK Modding Discord Admin: Join here!

  36. #76
    0
    Quote Originally Posted by StudioWildcard View Post
    (Btw the next Worldwide ARK Dev Kit contest will be announced after the Alienware Contest concludes, so in about a week! This next one will be worldwide and will have different competition tracks for Total Conversion, Mod, and Maps respectively! So keep at it )
    Cool, a new contest. When do we hear more about it? Are we allowed tp enter with the same mods as in the Alienware contest?
    Check out my ARK Mod Play As Dino!

  37. #77
    0
    Quote Originally Posted by WoefulMacabre View Post
    That's the entire point, and the drawback, of Total Conversions. They replace the files the clients/server uses.

    The PrimalGameData's in the DevKit don't contain the content of the 226.3(Live clients) PrimalGameData's so they will not show up. This is why core-data mods and TC's especially need to be updated with DevKit updates... it's also why people constantly ***** on steam when a TC locks out content when they don't realise that modders have no say, sway or power to do anything. We're at the mercy of Wildcard and their release schedule.

    -WM
    Hence the reason I stopped modding for this game.

  38. #78
    0
    malware detected in Ark-Dev-Kit-release\Engine\Plugins\Developer\BlankPlugin\Binaries\Win64\UE4Editor-BlankPlugin.dll found Trojan:Win32/Pocyx.gen!B!plock

    Are the github files infected?

  39. #79
    0
    No new binaries needed? and great job with the update and new modding system cant wait to mess around with it

  40. #80
    0
    Quote Originally Posted by yazoo32 View Post
    malware detected in Ark-Dev-Kit-release\Engine\Plugins\Developer\BlankPlugin\Binaries\Win64\UE4Editor-BlankPlugin.dll found Trojan:Win32/Pocyx.gen!B!plock

    Are the github files infected?
    Probably using Windows Defender right? if so, there is your problem ;-)

Page 2 of 15 FirstFirst 123412 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •