User Tag List

Page 3 of 4 FirstFirst 1234 LastLast
Results 81 to 120 of 143

Thread: Perception Neuron Template

  1. #81
    0
    @spaceharry: It is the same :-)
    Or did you mean the new official plugin from Weibo here:
    https://forums.unrealengine.com/showthread.php?103698-PerceptionNeuron-Unreal4-plugin

    Best regards
    Heiko aka Cyxx
    Last edited by Cyxx; 03-22-2016 at 06:55 AM.

  2. #82
    0
    Quote Originally Posted by Cyxx View Post
    @spaceharry: It is the same :-)
    Oh ok . Beautiful things you guys did!

  3. #83
    0

    v0.5.0 released

    Changes since last version:

    Changes plugin v0.3.0:
    - Add better custom skeleton handling. No need to map bone coordinate systems by hand anymore, just map the bone names in anim and event graph.
    - Mark old neuron read functions as deprecated
    - Add BVH player rewind node
    - NeuronRead functions are now able to read the skeleton translation and rotation in component space
    - Compile pre build libraries with UE4.10
    - Further comments and minor improvements

    Changes template v0.5.0:
    - Cleanup of all Animation BP and switch to new NeuronReadArray function which improves the support of custom skeletons.
    - Remove old custom bone mapping functions (are now deprecated)
    - Add function in Animation BP to remove pelvis drift on ground
    - Change project to UE 4.10
    - Update to Plugin v0.3.0

  4. #84
    0

    Recording solution

    Here a video of my new recording enhancements in the template/plugin.
    Sorry, currently not part of the free version. Send me a PM if you are interested.

  5. #85
    0
    Mmmhh....Testing it right now:

    I'm on 4.11 Preview 8, I set Axis to broadcast at ip 127.0.0.1 with port 7001 and I'm using the template done by Heiko, but if I hit play on Axis and then on UE4 nothing happens....looks like there's something wrong somewhere and I can't figure it out

    What should I check?

    I already changed the Neuron Anim Blueprint to use the BP Network but doesn't work...

    Could you help me out guys?

  6. #86
    0
    I just tried the template and UE4.11p8 again.
    But no problem, everything seem to work fine.
    Did you set in Axis Neuron the broadcasting to TCP, BVH, port 7001 and format 'String'?
    Does the local animation player on the purple Neuron character work and only the network fails?
    Best regards
    Heiko

  7. #87
    0
    My bad, I forgot the "String" setup!
    It works and it's pretty good

    By the way, other then the recording inside UE4 ( which is quite interesting ) there are any additional features? I'm really interested in having a faster iteraction between the realtime movement and Axis receiving the signal, and right now thew latency is a bit annoying...
    Any chance you unlock/hacked the suit in order to get raw data without Axis? that would be sweet!
    In case please send me a PM with the features detail, I'm quite interested in new plugins development, also because I'm about to connect the suit with the GearVR and then a custom HMD, so a faster response from the suit inside the EU4 environment is vital for my project

    Edit: I also notice that the newer version of the Mannequin ( the one on the right ) has some weird joints orientation on the clavicle and forearms.
    Last edited by Enter Reality; 03-29-2016 at 08:50 AM.

  8. #88
    0
    Making great progress with your plugin, and now a have a blueprint networked game working with my neuron suits.

    However, I'm now getting this error with Unreal 4.11.2, when building a new project from your v5 template.

    Name:  plugins.needing.recompiled.JPG
Views: 500
Size:  25.6 KB

    But, when I choose to recompile from the prompt, I get another prompt telling me to recompile manually.

    Name:  plugin.rebuild.from.source.JPG
Views: 496
Size:  17.5 KB

    I'm new to the C++ side of things, and have started a download of 4.11 from github. Do i just put the Plugins
    directory in the github repository and rebuild the engine to recompile these?

  9. #89
    0
    Hi alltrueist
    I have uploaded a new 4.11 version on GitHub, compiled with the latest 4.11.2.
    The last ones were compiled with 4.11p8.
    Please try again.
    Best
    Heiko

  10. #90
    0
    Quote Originally Posted by Cyxx View Post
    Hi alltrueist
    I have uploaded a new 4.11 version on GitHub, compiled with the latest 4.11.2.
    The last ones were compiled with 4.11p8.
    Please try again.
    Best
    Heiko
    That fixed it. Thanks.

  11. #91
    0
    I feel like I'm only missing a small thing, but the movements aren't mapping properly to my custom mesh. I've followed the 0.3.0 instructions and gone over everything several times; all the bones are getting data, they all (except hips) are set to ignore transform, they don't have any default rotation and still it's a mess. I'm using an auto-rigged mesh from Mixamo Fuse, if that gives anyone a clue.

  12. #92
    0
    Hi MrCheese,
    for custom rigs you have to map the bone names at the moment in two lists.
    On each node in the Anim Graph and in the Bone Map Array in the Event Graph.
    Hope this helps.
    Best regards
    Cyxx

  13. #93
    0
    Cyxx,

    Thanks for replying. I've done that, triple checked it. I've put my model in to your example and it looks like the bones are backwards or something, looks like I might have to learn rigging after all.

    Name:  bones.PNG
Views: 476
Size:  723.6 KB

  14. #94
    0
    MrCheese, if you want I can have a look into your character. Just send me a link with it as PM.

  15. #95
    0
    Ok, I've changed the Rotate Order to match the one in the Neuron output settings and it made no difference. The bones are definitely all rotating in the opposite direction.

  16. #96
    0
    MrCheese, thanks for the model. I send you the working project as a PM.

  17. #97
    0
    Cyxx very kindly and quickly found the problem: "Inverse Forward" was enabled on the "Read Neuron Motion Array" BP node in the event graph. I thought I'd say it here, in case anyone else needs the same help.

    Thanks again!

  18. #98
    0
    I'm still having trouble just getting Axis to talk to the Unreal plugin, but I'm pretty sure something is off in my settings. Could you take a look and tell me if anything jumps out to you as wrong? I am using Axis version 3.6.32... and your 4.10 template in Unreal.
    Name:  broadcasting_settings.jpg
Views: 395
Size:  69.1 KB
    Name:  output_format.jpg
Views: 399
Size:  61.0 KB

    Thanks.

  19. #99
    0
    Hi MattMerrill
    please change under Broadcasting to TCP protocol and the BVH format to String.
    Best
    Heiko

    Name:  Axis1.jpg
Views: 398
Size:  22.3 KB
    Name:  Axis2.jpg
Views: 401
Size:  23.3 KB

  20. #100
    0
    That did it. Thanks!

  21. #101
    0
    Me again.

    I'm following in the footsteps of Mr Cheese, trying to set up my custom character now. I'm also using a Mixamo character, but I'm having trouble even getting the character to move. I noticed that the Mixamo rig happens to use the same skeleton(with the same naming scheme) as the HeroTPP rig. So I duplicated/retargetted the HeroTPP_Neuron_AnimBlueprint onto my mixamo character. I checked the Bone map array as well as the Transform(Modify) Bone nodes in the animgraph and all the bone targeting seems to be in order.
    Then, of course, I linked my character blueprint to the animblueprint, put my character blueprint in the scene and hooked it up to the controller in the level blueprint.
    But alas, when I run the simulation and play the animation in Axis, the demo characters move, but mine does not. Have I completely overlooked something? Am I missing any steps? Is there anyway to debug where the data is choking?
    Thanks.

  22. #102
    0
    Hi Matt
    if your character does not move at all, then please check following points:
    - Level BP: If you use a network connection, is the network controller connected to your animation BP?
    - Is your network controller configured accordingly (IP, Port,...)
    For testing just use the same controller that already works for the HeroTPP.
    - Level BP: Is your character directly placed into the world or did you capsule it with a BP like the HeroTPP?
    Please check if you get the animation instance correctly. This is different for the both cases.
    For skeletal meshes use the skeletal mesh component reference (like Mannequin) and
    for character based BP use the mesh reference (like HeroTPP).
    Please check if the cast to your specific animation BP is successful,
    for instance with a print at the "Cast failed" pin.
    - Animation BP: Please check if the correct controller (for e.g. network) is connected.
    For debugging you could also set a breakpoint or connect a print to the "Read Neuron Motion Array" node and
    check if rotation or translation values are coming in.
    - If nothing helps you could send me also your project if you want.
    Best regards
    Heiko

  23. #103
    0
    Wow, I guess I am pretty dumb. I thought I'd been thorough in my troubleshooting, but apparently I completely overlooked the fact that the "Cast to..." and "set" nodes were specific to each anim blueprint. Previously I had only swapped out the actor reference. Anyway, it's working now! Hallelujah. Thank you.

  24. #104
    0
    Hey guys will this plug work with an 11 neuron setup...

    I'm wondering how many customization's I can get away with.

    For example upper body only, hands only, legs only etc

  25. #105
    0
    I've been trying out your plugin and I must say, it is a vast improvement over the official PN Unreal plugin. I'm having some difficulty connecting the template to Axis Neuron on the same computer though. Am I supposed to connect via TCP or UDP? Does the avatar in Axis Neuron's side need to have a specific name, or is there a place in Unreal's side to set that name? Maybe it's not even needed. I appreciate all your work and help, hopefully I'll be able to make a donation in the coming days.

    Edit #1:
    It turns out that downgrading from Axis Neuron Pro to a normal version of Axis Neuron fixed this problem for me. Have you had any luck getting your plugin to work with Axis Neuron Pro?

    Furthermore, I was also hoping you could give me some insight into where to tweak the Mannequin bones to have more accurate movement for characters with an A Pose. Even though all the limbs manage to stay together in the correct place, their rotation seems to be off. Do you have any suggestions?
    Last edited by churly92; 07-21-2016 at 11:28 AM.

  26. #106
    0
    What exactly is the "set" node referring to? how do I find it?

  27. #107
    0
    Hi @Cyxx,

    First off, thanks for the plugin mate, it's pretty awesome.

    I am facing one kind of weirdness though: when I try to do a 180 degree turn, the model (my custom one, or the default one you gave in the template) never matches the rotation of my real world pose. And, on top of it, the movement goes all wonky. This is especially true when I put on the oculus. As long as I'm facing down the positive X-Axis in Unreal (the front in Unreal), my movement matches everything 1:1. The minute I make a 180 turn, boom. My character stops rotating past a certain point, and actively moves in the opposite direction of motion.

    I tried printing out the rotation values for the Hips bone, the roll value goes between -180 to 180. Could that be the issue (to me that looks like the main issue)?

    Could you clue me in to this problem? Any insight would be great.

  28. #108
    0
    Sorry for the late answers. I was quite busy to check the thread and got no mails from the forum SW.
    If you need a quick answer write me a PM (seems to work better) or contact me over Skype.

    @310Thirty:
    The plugin works with any number of Neurons as long as this combination is supported by Axis Neuron Player.
    'Upper body' and 'hands only' works good, but 'legs only' I didn't tried yet.

    @churly92:
    The plugin uses TCP for the connection. Axis Neuron Pro works fine here.
    Please check the following settings in Axis Neuron:
    Output format: Rotation: XYZ, Displacement: Enabled (if not needed, disable it also in your BP controller node)
    Broadcasting: TCP: Enabled, BVH: Enabled, Port: 7001 (or change it also in BP controller node), Format: String, Use old header: Disabled

    A-Pose configuration:
    Please have a look into the grey Mannequin animation BP.
    In the animation graph, after the "Initialize Animation" there is an example how to map your A-Pose to the T-Pose.
    Add here all the additional angles and all the bones to match the T-Pose.
    It currently works not perfect, but helps in some cases.

    @Dracomancer:
    I think you mean the answer from Matt. He had a problem in his Level BP.
    If you add a new skeleton you must inform the Anim BP which BP controller should be used.
    This is currently done in the Level BP.
    But you have to take care here which method you are using for configuration.
    For skeletal meshes use the skeletal mesh component reference (like Mannequin) and
    for character based BP use the mesh reference (like HeroTPP).

    @mdhananjay:
    So far I had no problem with the hips rotation in Unreal.
    Can you check the animation in Axis Neuron?
    Is the character rotation there like you wish?
    If yes and the plugin makes something wrong, please send me a short Axis Neuron recording about it and I will have a look into it.

  29. #109
    0
    @Cyxx

    The animation in Axis was exactly as I needed it to be. After a lot of playing around, I found that, weirdly, the camera setting "Lock to HMD" was the culprit. Turned that off and voila! Worked like a charm.

  30. #110
    0
    Thanks Allot for the response!!!

  31. #111
    0
    Hi Heiko,

    I am evaluating your plugin for our project and experiencing some issues with parsing bvh animation stram coming from Neuron Axis over TCP in your PerceptionNeuronControler.cpp file. Particulary with counting floats in motionline on Tick. It results in the wrong value of FloatCount and NeuronRead function fails. I use UE 4.12, Neuron Axis 3.7.42.

    Any suggestions are welcome.

    Thank you!

  32. #112
    0
    Hi Cyxx,

    My team and I have been using three PN for a couple of months and have a serious problem with hands tracking precision.
    If you clap hands, then the palms permeate through each other in Axis Neuron. This is just begenning! If you start raising or moving down the hands (the palms pressed to each over), we see in Axis different picture. In case if I move the hands down then the palms are moving away from each other (in Axis neuron). In case if I raise the hands then the palms penetrate each over more and more. In reality, the arms move only up and down and remain pressed against each other.

    We have tried to calibrate each sensor and the suit in general, but it hasn't helped us. We tested it on several people and used different body parameters, but it didn't help
    Have you had such a problem? Could you please suggest any way how it is possible to fix it?

    One more issue with PN: the longer we use PN the tracking becomes less pricecly. For example, after 30-40 minutes, the tracking precision of hands and legs not so accurate. After calibration (3 poses) it becomes pretty precisely again. Is there exist any way to avoid this problem?

    Thank you!

  33. #113
    0
    @BlobTheToymaker: As already wrote per mail, please open the project in the template not directly.
    Follow the installation instructions. Copy the template to your Unreal template folder and create a new project out of it.

    @vanipel:
    The PN suit uses IMU sensors to measure the acceleration (not position!) and rotation in the earth magnetic field.
    Because of that, the absolute position is always an approximation and will be not as good as e.g. optical solutions.
    But you are not alone, I have the same problems with the absolute positioning.
    For animation recording my solution is to clean up the motion data later in an animation tool (Maya, Blender, ...) and correct the absolute position there.
    If you want to use the suit for live animations (like VR) and rely on absolute positions, then it is better to combine the suit with other hardware, like HTC Vive controllers.

    Here are also some basic tips and tricks to get better results:
    (I think you aready know them, but may be its useful for other users)
    - The very basic tip first:
    Please make sure that you follow the 3 keys of good MoCap (Good Environment, Good placement of Neurons, Good calibration poses) explained here in this Noitom Video:
    https://www.youtube.com/watch?v=hJFnyOVstsg
    - Measure the length of your actors bones and the distance between the joints and put the numbers into the 'Body Size Manager' in Axis Neuron.
    Explained here in this second Noitom video (which has also some other useful tips):
    https://www.youtube.com/watch?v=6Qm5qWIeAWc

  34. #114
    0
    Hey Cyxx,

    I recently updated my project to 4.13, and I'm getting this error at runtime using the newest 4.13 binary version of the plugin.
    There are no errors loading the editor so i wonder if the plugin also needs compiled for 'Developement' as well as 'Development_Editor'
    or something. Is the compiled version working at runtime for you in 4.13?

    Error attached:
    Attached Images Attached Images  

  35. #115
    0
    @alltrueist:
    Just tried the Perception_Neuron_Plugin_0.3.1_UE4.13.zip again with a new BP based project, but I have no problems here with packaging and starting the runtime.
    Could you check if you installed the new files into the correct folder and may be remove the old intermediate folder "Plugins\PerceptionNeuron\Intermediate"?

  36. #116
    0
    @ Cyxx
    Thanks for verifying everything working in 4.13. Turns out I forgot to update my batch script which launches my -game to '4.13' from '4.12' which explains why it was working in editor but not at runtime. Bonehead Move. Sorry about that.

  37. #117
    0
    @Cyxx

    Using 4.13.2, latest plugin ( 0.3.1 ) and every time I finish with the setup ( set neuron blueprint and player ) I have a hard crash.

    Tested with 4.12.5 everything works fine

    Here is the crash log for 4.13

    Access violation - code c0000005 (first/second chance not available)

    UE4Editor_Sockets
    UE4Editor_PerceptionNeuron!APerceptionNeuronController::Connect() [e:\projects\unreal\tp_neuron\plugins\perceptionneuron\source\perceptionneuron\private\perceptionneuroncontroller.cpp:260]
    UE4Editor_PerceptionNeuron!UPerceptionNeuronBPLibrary::NeuronConnect() [e:\projects\unreal\tp_neuron\plugins\perceptionneuron\source\perceptionneuron\private\perceptionneuronbplibrary.cpp:93]
    UE4Editor_PerceptionNeuron!UPerceptionNeuronBPLibrary::execNeuronConnect() [e:\projects\unreal\tp_neuron\plugins\perceptionneuron\source\perceptionneuron\public\perceptionneuronbplibrary.h:168]
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_CoreUObject
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_Engine
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor_UnrealEd
    UE4Editor
    UE4Editor
    UE4Editor
    UE4Editor
    UE4Editor
    kernel32
    ntdll

  38. #118
    0
    @Enter Reality:
    Sorry to hear that you had a crash.
    Did you change the hostname (127.0.0.1) in the Neuron Controller Actor and if yes what name are you using?
    When does the crash occur exactly? Immediately after you hit "Play", when starting your packaged game or in the editor?
    Is Axis Neuron SW running in that time?
    Do you use any specialities in your network setup?
    Does the crash occur with the original template?

  39. #119
    0
    Thanks for the fast reply

    Host name is the same.
    The crash happen as soon as I hit play, it doesn't even start ( both in the editor and standalone game )
    Axis ( not latest version but 3.7.42.5837 ) is running
    No special setup for the network
    Original template doesn't work for me, on 3 different PC I have the same error ( see below )
    An error occurred while trying to generate project files.

    Running C:/Program Files (x86)/Epic Games/4.13/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project="D:/UE4_Projects/MyProject2/MyProject2.uproject" -game -rocket -progress
    Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that "Common Tools for Visual C++ 2015" was selected when installing Visual Studio 2015.
    Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that "Common Tools for Visual C++ 2015" was selected when installing Visual Studio 2015.
    Discovering modules, targets and source code for project...
    UnrealBuildTool Exception: ERROR: Failed to find cl.exe in the default toolchain directory C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\../../VC/bin/x86_amd64\cl.exe. Please verify that "Common Tools for Visual C++ 2015" was selected when installing Visual Studio 2015.

    I do have Common Tools installed by the way, so I'm not sure this error appears...

    Also because on version 4.12.5 I'm able to use the plugin without any issues

  40. #120
    0
    @Enter Reality:
    Very strange. No problem here with both template or binary plugin in UE4.13.2 and Axis 3.7.42.5837.
    Did you upgrade an existing project to 4.13.2 and reinstalled the plugin or tried setting up a new project?
    If you upgraded, did you remove the PerceptionNeuron plugin folder completely and installed the new one?
    Removed all Intermediate folders?

    And may be you have an VS installation problem.
    Since the PN template is based on the original C++ template "Third Person", could you try creating and compiling a new 4.13.2 project based on that one?
    Does the above "generate project files" errors occur also there?

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •