User Tag List

Page 7 of 7 FirstFirst ... 567
Results 241 to 249 of 249

Thread: 4.15 Released!

  1. #241
    1
    Any hints about how many more hot fixes are coming before 4.16 previews begin to be planned for ? (I really need that new audio engine for Gear VR )

  2. #242
    0
    Unreal Engine Developer
    Join Date
    Mar 2014
    Posts
    1,157
    Quote Originally Posted by ddbrown30 View Post
    Is there some documentation of how to correctly get hotfixes using the stream system?
    Since you have P4 access, please ask your question on the UDN and we'll follow up there.
    Stephen Ellis | Lead Engine Support Technician | Epic Games | @TheEpicStephen
    How to report a bug | >>Click here to report a bug<<

  3. #243
    1
    Unreal Engine Developer
    Join Date
    Mar 2014
    Posts
    1,157
    Quote Originally Posted by motorsep View Post
    Any hints about how many more hot fixes are coming before 4.16 previews begin to be planned for ? (I really need that new audio engine for Gear VR )
    We are considering one more 4.15 hotfix, but it will likely be just for a few specific updates. Most of our attention is now focused on 4.16.

    Cheers
    Last edited by Stephen Ellis; 03-23-2017 at 02:14 PM.
    Stephen Ellis | Lead Engine Support Technician | Epic Games | @TheEpicStephen
    How to report a bug | >>Click here to report a bug<<

  4. #244
    0
    Quote Originally Posted by Stephen Ellis View Post
    Hi dgrieshofer.

    I'm sorry to hear that your users are experiencing this, but no, unfortunately this is not a known issue to us. Our QA tests with AMD cards have not uncovered any issue, and I am not currently aware of any other developers reporting a similar issue.

    It seems that your user's crashes are being reported to our CrashReporter service. I've looked at a few, unfortunately they contain no callstack or source code reference on our end. This typically means that the crash is not occurring in the default engine code, but rather in custom code.

    Cheers
    Hey @Stephen Ellis,

    thanks for letting me know. Regarding crash reports without callstacks/references, this is due to me not having included the debug symbols. I only included the debug symbols on an experimental build for getting the logs however then forgot to include the crash reporter on that version.

    Either way I had to revert to 4.14 for now. By the way I have no custom code other than including Steamworks 1.39 (which you do for 4.16 too) and since the engine crashes on launch and only on some AMD GPUs I find it very unlikely that this is caused by me. I guess you did not have a large enough test sample size yet to catch this issue.

    Anyway thanks again and please let me know if you have any more information.

    EDIT: Seems like other people have this issue too: https://answers.unrealengine.com/que...e-players.html
    Last edited by dgrieshofer; 03-25-2017 at 04:16 PM.

  5. #245
    0
    Having a CTD when creating a new project and saving with the project settings window open. The project launches for a split second, pulls up the project settings window, then disappears. I submitted the issue when it happened but figured I'd mention it here -

  6. #246
    0
    Hi Stephen Ellis. Really appreciate your work on engine!
    After installing hotfix my blueprint with casting of actor to base class is not working anymore... Not sure is it a bug or my fault.

    http://imgur.com/qNokwgV
    http://imgur.com/eOzjGNM

    P.S. For some reason can't attach image to post, just added links to it.

    Sorry, everything is ok now, just restart editor twice...
    Last edited by Leaffall; 03-25-2017 at 08:17 AM.

  7. #247
    0
    Samaritan
    Join Date
    Mar 2015
    Posts
    138
    Quote Originally Posted by dgrieshofer View Post
    @Stephen Ellis Are you already aware of any engine startup crashes like this one which started to happen in 4.15 on AMD (with possibly older drivers) having the following callstack?:
    Code:
    Fatal error!
    
    Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x909005f3
    
    FD3D11DynamicRHI::InitD3DDevice() [d:\unrealengine\engine\source\runtime\windows\d3d11rhi\private\windows\windowsd3d11device.cpp:1080]
    RHIInit() [d:\unrealengine\engine\source\runtime\rhi\private\dynamicrhi.cpp:181]
    FEngineLoop::PreInit() [d:\unrealengine\engine\source\runtime\launch\private\launchengineloop.cpp:1644]
    GuardedMain() [d:\unrealengine\engine\source\runtime\launch\private\launch.cpp:127]
    GuardedMainWrapper() [d:\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:147]
    WinMain() [d:\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:210]
    __scrt_common_main_seh() [f:\dd\vctools\crt\vcstartup\src\startup\exe_common.inl:253]
    kernel32.dll!0x000000007745336A
    ntdll.dll!0x0000000077B89902
    ntdll.dll!0x0000000077B898D5
    ntdll.dll!0x0000000077B898D5
    having the exact same issue (only after installing the hotfix x.x.1) do you guys know what's going on?
    "Today a young man on acid realized that all matter is merely energy condensed to a slow vibration. That we are all one consciousness experiencing itself subjectively. There is no such thing as death, life is only a dream, and we are the imagination of ourselves. Here's Tom with the weather."

  8. #248
    0
    Quote Originally Posted by Vasault View Post
    having the exact same issue (only after installing the hotfix x.x.1) do you guys know what's going on?
    Interesting, when I reported this issue back then I already had used a version using all but the last few 4.15.1 commits. Do you have this crash in the editor? If so please make sure to send the reports to Epic and I would personally also be interested in your system specs.

    Btw if what you are saying is true then the crashes might have been caused by any commits between 4.15 release (CL 3299760) and the one which I was using (CL 3341735).
    Last edited by dgrieshofer; 03-27-2017 at 06:10 AM.

  9. #249
    0
    Samaritan
    Join Date
    Mar 2015
    Posts
    138
    Quote Originally Posted by dgrieshofer View Post
    Interesting, when I reported this issue back then I already had used a version using all but the last few 4.15.1 commits. Do you have this crash in the editor? If so please make sure to send the reports to Epic and I would personally also be interested in your system specs.

    Btw if what you are saying is true then the crashes might have been caused by any commits between 4.15 release (CL 3299760) and the one which I was using (CL 3341735).
    only after opening a project, the editor launcher works perfectly fine, only after i open a project, it crashes
    "Today a young man on acid realized that all matter is merely energy condensed to a slow vibration. That we are all one consciousness experiencing itself subjectively. There is no such thing as death, life is only a dream, and we are the imagination of ourselves. Here's Tom with the weather."

Page 7 of 7 FirstFirst ... 567

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •